Z06Vette.com - Corvette Z06 Forum - View Profile: mikefeeser

mikefeeser mikefeeser is offline

Z06 Member

  Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. mikefeeser
    11-01-2012 03:32 AM - permalink
    mikefeeser
    Battery Problem:
    Having an electrical issue - 2001 Z06, about 62,000 miles. Went out this morning to start the car - removed Battery Tender that has been connected for about 6 days. Battery Tender had a green light when I disconnected it. Went to start the car and got: click - click - click etc. (I am sure you all know that song).

    I installed a new Die-Hard battery in Nov 2008, car had about 48,000 miles at that time.

    For a comparison - Also have a 2004 Vette Coupe, it still has the original battery (and it is usually on a Battery Tender also). Never seem to have a problem with that - it has about 35,000.

    Why did the Battery Tender have a green light but the car will not start? Is this battery dead? Any ideas?

    thanks

    Mike Feeser
  2. mikefeeser
    03-04-2012 03:25 PM - permalink
    mikefeeser
    My Oil Pressure Sensor has failed - I realize I could go for some time without it - but want to get it fixed - can somebody give me a ball park figure as to the cost of the Oil Pressure sender unit.

    thanks

    mike

  About Me

  • About mikefeeser
    Location
    New Oxford, PA
    Interests
    Cars, Road Races, Photography
    Occupation
    Retired USAF & Programmer
    Ride
    2001 Z06, 2004 Coupe
    Tranny type
    Manual
    Tires
    Street Radials

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 11-26-2015 06:21 AM
  • Join Date: 01-25-2006
  • Referrals: 0

  Mentions

No results to display...

  Quotes

No results to display...
 
For the best viewing experience please update your browser to Google Chrome