Michelin Problem - Z06Vette.com - Corvette Z06 Forum
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 4 (permalink) Old 08-10-2019, 01:26 PM Thread Starter
ricktret
Junior Member
 
Join Date: Aug 2003
Location: California
Posts: 6
Michelin Problem

I needed tires for the front of my 2016 Z06, and decided to go with the stock Michelin Pilot Super Sports. I bought the tires and took them in to be mounted and balanced. After 90 minutes of trying to seat the bead, they told me they couldn't get the bead to seat. The guy was nice enough to suggest another shop more familiar with performance tires. I went there and had the same problem. The owner told me he had seen this before with these tires, and though not frequent some of the tires seemed to be a little out of spec. The seller told me he had never heard of such a problem and told me that if I would drive them to his installer they would get it done. His installer worked the tires for two and a half hours before giving up.

I've got a new set of tires being shipped Monday so I'll see if they're better. I was told by one of the installers that Michelin is aware of the problem but will not acknowledge it as it is infrequent.

More to follow.
ricktret is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-10-2019, 06:42 PM
jub jub
Moderator
 
jub jub's Avatar
 
Join Date: Feb 2003
Location: God's Country
Posts: 21,254
Re: Michelin Problem

Quote:
Originally Posted by ricktret View Post
I needed tires for the front of my 2016 Z06, and decided to go with the stock Michelin Pilot Super Sports. I bought the tires and took them in to be mounted and balanced. After 90 minutes of trying to seat the bead, they told me they couldn't get the bead to seat. The guy was nice enough to suggest another shop more familiar with performance tires. I went there and had the same problem. The owner told me he had seen this before with these tires, and though not frequent some of the tires seemed to be a little out of spec. The seller told me he had never heard of such a problem and told me that if I would drive them to his installer they would get it done. His installer worked the tires for two and a half hours before giving up.

I've got a new set of tires being shipped Monday so I'll see if they're better. I was told by one of the installers that Michelin is aware of the problem but will not acknowledge it as it is infrequent.

More to follow.
Thanks for the heads-up. I have never heard of such a problem with the pilot sports.

jub jub is offline  
post #3 of 4 (permalink) Old 08-13-2019, 08:20 AM
MSiska
Moderator
 
MSiska's Avatar
 
Join Date: Nov 2001
Location: Texas
Posts: 20,612
Re: Michelin Problem

When I replaced the runcraps on my 06, I had TR ship Pilot SS's to Pat Goss's garage for installment. After install, he said the right front was out of spec. And wanted to know if he should ship back to TR and get a new one. I asked him how out of spec it was. He told me he had it up to 90 and it was fine. So I trusted him and said to keep the tire on. It was fine for the driving I did. But the out of spec tires happens, but hopefully it will be rectified.

Z06Fest Addict: I II III IV V VI VIII IX X XI
MSiska is offline  
 
post #4 of 4 (permalink) Old 08-13-2019, 05:06 PM Thread Starter
ricktret
Junior Member
 
Join Date: Aug 2003
Location: California
Posts: 6
Re: Michelin Problem

Got the replacement tires today and Tire Pros worked on one for three hours before giving up. Does anyone know of a tire shop in Las Vegas that might be able to handle an install? I don't think it could still be the tires, there must be some special technique.
ricktret is offline  
Sponsored Links
Advertisement
 
Reply

  Z06Vette.com - Corvette Z06 Forum > Other Z06 Topics > Wheels, Tires, and Brakes


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome