Need help with mystery compression readings - Z06Vette.com - Corvette Z06 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-05-2019, 02:36 PM Thread Starter
bmoss1457
Junior Member
 
Join Date: May 2019
Posts: 2
Need help with mystery compression readings

I have a 2003 Z06, 140k miles with no previous issues. While moderately driving I suddenly lost significant power, feeling like I lost at least two cylinders. I limped 5 more mile to home.
No unusual noises excepts what sounded like compression bursts from passenger side somewhere. Fuel check good, spark good, plugs good. It got interesting with compression check.
#1, 2. 4 and 8 only had 25-35psi and the rest had non. on second round little to no compression on any. On third round #1,2,4 and 8 again had very low reading. Timing chain has considerable slack but no jump and marks are fairly aligned. Crank feels really hard to turn by hand at points, enough that I was forced to bump the starter to continue. Any opinions where to look next? Would excessive slack in the timing chain cause timing to be off that bad?
Can anyone tell me just how much slack or deflection in the timing chain can be tolerated before potential damage to valves or pistons?

Last edited by bmoss1457; 05-05-2019 at 05:46 PM.
bmoss1457 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-06-2019, 07:15 PM
jub jub
Moderator
 
jub jub's Avatar
 
Join Date: Feb 2003
Location: God's Country
Posts: 21,234
Re: Need help with mystery compression readings

Sounds like you blew both head gaskets. I have never seen both head gasket let go but I have no other ideas as to what could have happened. Were you using NOS or running boost?

jub jub is offline  
post #3 of 4 (permalink) Old 05-07-2019, 06:03 AM Thread Starter
bmoss1457
Junior Member
 
Join Date: May 2019
Posts: 2
Re: Need help with mystery compression readings

Yes it does, doesn't it? That was my first thought. No water in the exhaust, oil was clean, and cooling system pressure was good. It just feels, like a timing issue. It bothers me that the crank gets into a bind about every quarter spin by hand. Its possible I guess, the chain is binding on a sprocket although they look okay, the best I can see with chain on. Going to replace them and check compression again. I just learned about interference engines, and now I'm really nervous!! lol
Thinking back, I remember some pre ignition ping during hot weather last season. At this point, pulling heads for top end service seems a good idea anyway and I'll see more of whats going on, maybe.
bmoss1457 is offline  
post #4 of 4 (permalink) Old 05-07-2019, 09:36 AM
racingvette
Z06 Tech Advisor
 
racingvette's Avatar
 
Join Date: Nov 2008
Location: USA
Posts: 1,791
Re: Need help with mystery compression readings

Have you checked to see if there is some bent valves or broken valve springs or lifters or push rods ?
As valve(s) stuck open would prevent the cylinder compression
Yank valve covers and check all

Did you do also do leak down tests ?

Mike M - 2001 / 2008 Z06s
racingvette is offline  
Sponsored Links
Advertisement
 
Reply

  Z06Vette.com - Corvette Z06 Forum > C5 Z06 Specific Topics > C5 Z06 - Grandstand


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NEED HELP...Built Mystery C6Z Frank King Car HOSTIL C6 Z06 - Grandstand 6 09-06-2013 07:04 AM
Help with AUTO TAP readings 22655TD C5 Z06 - Tuning & Electronics 9 04-28-2003 03:57 PM
What is the difference in O2 readings before/after cats. FRISKY C5 Z06 - Pit Road 15 07-06-2002 09:32 PM
autotap readings and a question or 2 SSpray C5 Z06 - Pit Road 2 07-01-2002 04:17 AM
ODO Readings?????? atuttavelocita C5 Z06 - Grandstand 19 09-01-2001 10:04 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome