HELP, Need expert advise! - Z06Vette.com - Corvette Z06 Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-09-2014, 08:15 PM Thread Starter
BRIANW401
Z06 Member
 
BRIANW401's Avatar
 
Join Date: Jul 2010
Location: Garden City, Kansas
Posts: 62
HELP, Need expert advise!

I just performed what seemed to be the simple task of replacing the clutch master cylinder in my C5 Z06 & now the clutch pedal won't budge. The damn thing is rock solid. Everything came apart & went back on relatively smooth. The reservoir is full of fluid & there are no leaks anywhere. What could be the problem? The unit is a GM stock replacement & it came already filled with fluid which I thought was odd. Does anyone have a reason why the pedal wont budge? It moves very easy when the master cylinder rod is not connected, so the pedal itself is fine. Any input will be greatly appreciated. Thanks!
BRIANW401 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-10-2014, 07:14 AM
racingvette
Z06 Tech Advisor
 
racingvette's Avatar
 
Join Date: Nov 2008
Location: USA
Posts: 1,797
Re: HELP, Need expert advise!

It comes with the fluid in so that the master/slave do not have to be bleed

You sure the master hose coupler is fully seated to the slave coupler ?
as if fluid cannot move then there would be no movement for rod in master

Mike M - 2001 / 2008 Z06s
racingvette is offline  
post #3 of 4 (permalink) Old 05-10-2014, 07:16 AM
eagle7175
Z06 Addict
 
eagle7175's Avatar
 
Join Date: Apr 2012
Location: somewhere
Posts: 109
Re: HELP, Need expert advise!

just guessing but since it came with fluid their might be a "shipping plug" installed to keep fluid from leaking out???? had a twin turbo engine once that one turbo wasn't putting out boost, turned out the shipping plug was still installed and assembly technician didn't remove it. wish you luck with this.
eagle7175 is offline  
 
post #4 of 4 (permalink) Old 05-11-2014, 07:20 PM Thread Starter
BRIANW401
Z06 Member
 
BRIANW401's Avatar
 
Join Date: Jul 2010
Location: Garden City, Kansas
Posts: 62
Re: HELP, Need expert advise!

Thanks for the input guys. I actually pulled it back out & went to the parts store & exchanged it out. The new one works flawlessly. I guess I just got a bad unit.
BRIANW401 is offline  
Sponsored Links
Advertisement
 
Reply

  Z06Vette.com - Corvette Z06 Forum > C5 Z06 Specific Topics > C5 Z06 - Pit Road


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pro Expert You Holding Out On Us? artnj04z06 The Parking Lot (non car related topics) 13 11-27-2007 05:15 AM
Need Your Expert Help: Should I get this '02 Z06 not_a_vetteran The Garage (non Vette related) 4 10-26-2007 07:43 AM
I need a KR expert....Help Please. Z06-Dave C5 Z06 - Pit Road 4 09-06-2004 04:31 PM
A Microsoft Expert diversion... sigung86 The Garage (non Vette related) 4 04-09-2002 01:01 PM
Need expert advise please TOMDEG C5 Z06 - Grandstand 9 02-20-2002 09:35 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome