ZR-1 battery corrosion - Z06Vette.com - Corvette Z06 Forum
 
LinkBack Thread Tools Rate Thread Display Modes
post #1 of 9 (permalink) Old 05-13-2012, 09:03 AM Thread Starter
Plakin
Z06 Member
 
Join Date: Mar 2003
Location: Tulsa, Ok.
Posts: 88
ZR-1 battery corrosion

My 2010 ZR-1 (8000 miles) would not start yesterrday-thought I had left something on but no, it was the positive side of the battery connection, which was HIGHLY corroded-the AAA guy said it was as bad as he had ever seen-I mean a big pile of "stuff" under the red plastic shield. We cleaned it up and it started up fine. I never thought to even look back there to see how the battery was. I only drive the car 300 miles per month. Also, the battery is rather difficuld to remove and a battery carrier is needed to get it out to clean up the mess left for this episode. Check this out from time to time. Probably not specific to the ZR-1.
Plakin is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-13-2012, 10:18 AM
MikesZ06
Administrator
 
MikesZ06's Avatar
 
Join Date: Mar 2002
Location: Kansas City
Posts: 21,250
Re: ZR-1 battery corrosion

Batteries have always been a bit of a hick-up with Vettes, no matter what model or year. Whatyagonnado :doh:

Mike


2002 Procharged (F1-C) 427LSX 821rwhp/751rwtq
9.87 at 141mph & 2007 Black C6 Z06
Vette Magazine article
1/4 mile pass
MikesZ06 is offline  
post #3 of 9 (permalink) Old 05-13-2012, 07:24 PM
Tomasy
Z06 Senior Member
 
Join Date: Apr 2002
Location: Jacksonville, FL
Posts: 2,018
Re: ZR-1 battery corrosion

That much corrosion at that mileage would make me want to check for an acid leak from the battery. Anything over 2 years on an oem battery is kind of borrowed time.
Tomasy is offline  
 
post #4 of 9 (permalink) Old 05-14-2012, 09:53 AM
racingvette
Z06 Tech Advisor
 
racingvette's Avatar
 
Join Date: Nov 2008
Location: USA
Posts: 1,784
Re: ZR-1 battery corrosion

If the battery cables was not correctly torqued to the battery posts that could happen
Make sure it is tight and then watch to see if it happens again

If it does then battery is defective and should be replaced.

Mike M - 2001 / 2008 Z06s
racingvette is online now  
post #5 of 9 (permalink) Old 05-14-2012, 10:49 AM
vant
Z06 Master
 
vant's Avatar
 
Join Date: Jan 2005
Location: Gulf Coast
Posts: 4,777
Re: ZR-1 battery corrosion

Quote:
Originally Posted by racingvette View Post
...
If it does then battery is defective and should be replaced.
That was my first thought. We're talking about a $100 battery in a $100,000 car. If it were me, I would just replace it now (the battery, not the car).

I need a new sig!
2004 MS/BLK Z06 / Toyo T1Rs / CAGS Defeat / Seat Bolster Mod / HPDE Checklist
vant is offline  
post #6 of 9 (permalink) Old 06-20-2012, 02:29 PM Thread Starter
Plakin
Z06 Member
 
Join Date: Mar 2003
Location: Tulsa, Ok.
Posts: 88
Re: ZR-1 battery corrosion

The dealership replaced the battery and the complete cable assembly. Working fine so far.
Plakin is offline  
post #7 of 9 (permalink) Old 12-09-2018, 07:38 AM Thread Starter
Plakin
Z06 Member
 
Join Date: Mar 2003
Location: Tulsa, Ok.
Posts: 88
Re: ZR-1 battery corrosion

The posts above were long ago-2012 -still have the very same ZR-1 with the same replacement battery as described above. Car now has 15k miles- 6 years or so later. The replacement battery has been perfect till this morning even though the car is not driven much. Temp outside is near 30 this morning and has been for a couple of days. Would not start so I hooked up the charger without disconnecting the terminals as I did not want to go through the reprogramming of all the "stuff"--you know what I mean. Question is, "should I disconnect the terminals for the in-car charging?". Charger looked like it was working fine-pegged out then fell back to 4 in 2 minutes or so. Second question is maybe this battery is on its last legs-you think? It is now close to 6 years old. Thx
Plakin is offline  
post #8 of 9 (permalink) Old 12-09-2018, 01:16 PM
Bruno
Z06 Addict
 
Bruno's Avatar
 
Join Date: Aug 2013
Location: Saint Louis
Posts: 187
Garage
Re: ZR-1 battery corrosion

It seems to me that all batteries only last about 6 years. I had to replace my battery this fall, the car is a '13, so from when I got it until I replaced the battery has been 5+ years.
All my Fords in the garage have had their batteries replaced between the 5 and 6 year time line.
I do however keep my Corvette plugged into a battery saver for the winter months when driving the car is really not an option. Winter came a little early this year as our weather has been cold and crappy since November started. Because these cars have so many controllers and on board computers running you need a constant power source. My tuner told me that every time you open the door the controllers run for about 15 minutes. So constant power draw leads to short battery life if you are not plugged in or driving the car frequently.

13 Z06 Blk/Blk Halltech mf103 Corsa sport axle back exhaust custom tune by Team ZR1 533rwhp 463rwtq 48lb/hr injectors
Bruno is offline  
post #9 of 9 (permalink) Old 12-19-2018, 11:13 AM
Hotrodron
Junior Member
 
Hotrodron's Avatar
 
Join Date: Nov 2018
Location: Massachusetts
Posts: 26
Garage
Re: ZR-1 battery corrosion

I agree with Bruno,I bought my 04 four years ago and,always kept it on a battery tender from Nov-April.It had an A.C.Delco battery in it and I didn't have a problem until this November.One day while it was on the tender I opened the door,& I heard a ticking sound coming from the battery.It only lasted a minute then stopped.I checked the battery & the tender and both seemed fine.But I noticed the indicator light wasn't changing back to green after 12 hours later(it stayed red).So with the advice from a friend I pulled the battery,and found it had a small crack near the post.Luckily I caught it in time before any damage occurred.I went with a new optima red top,which is supposed to be leak proof,and will replace it every 4 years from now on,for peace of mine.
Hotrodron is offline  
Sponsored Links
Advertisement
 
Reply

  Z06Vette.com - Corvette Z06 Forum > C6 Z06 Specific Topics > C6 - ZR1


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes Rate This Thread
Linear Mode Linear Mode
Rate This Thread:



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I remove surface corrosion from aluminum wheels? mlrs Wheels, Tires, and Brakes 12 04-20-2016 06:52 PM
lug nut corrosion XFordGuy C5 Z06 - Pit Road 4 08-30-2007 12:24 PM
Battery Corrosion Causes? nutbush The Garage (non Vette related) 2 06-19-2005 07:05 PM
PCM corrosion ppk1911 C5 Z06 - Pit Road 4 12-07-2004 04:22 PM
Battery Corrosion Stan2002 C5 Z06 - Pit Road 2 10-24-2004 09:40 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome