Corvette Z06 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,644 Posts
Discussion Starter · #1 ·
I store my 2002 C5 for the winter on a slow charger. This year I get nothing. No dash board lights or anything else when I turn the key on. I've tried different jump start batteries and different slow chargers, and nothing at all! I would assume with a jump the Z should start..(crank at least) even if the battery is dead. ANy ideas before I have it sent to a shop?
 

·
Super Moderator
Joined
·
667 Posts
SCONI!!! Is that you! I think if the battery is really dead, a jump won't work. But first thing I would do is check the voltage to see if there is any at the battery, then the cables and work my way from there. Any power at the starter? What is this 2002 C5?

Just look at that "Joined ...." date for both of us!
 

·
Registered
Joined
·
1,644 Posts
Discussion Starter · #3 ·
SCONI!!! Is that you! I think if the battery is really dead, a jump won't work. But first thing I would do is check the voltage to see if there is any at the battery, then the cables and work my way from there. Any power at the starter? What is this 2002 C5?

Just look at that "Joined ...." date for both of us!
Yuh, it's me! Though I have a 2002 Z06 since the demise of the 01. I never updated my profile. I get NOTHING when i put the key in and turn it. no clanger, no lights, zip. I'll check the battery for voltage.... How yuh doin?
 

·
Super Moderator
Joined
·
667 Posts
Sounds like the battery is a goner! All good here, still working. Hope to retire in a couple of years. Enjoying the ZL1 and now back in a Z06. Lots of fun switching back and forth. Totally different machines. So glad to back in a Z06. I love this car. Sad it took me so long.
 
1 - 5 of 5 Posts
Top