Corvette Z06 Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello, I have a 2010 ZR1 that I recently bought. On a cold start, it will start and idle up and down then die. Then it will start normally and the second try. I had a tuner come by and tuned it and told me to turn the car on for 4 seconds to allow the fuel pump to pull the fuel up to the engine. It works right when I do that. But what could keep the fuel from draining the fuel pump after sitting all night? Thanks for your time.
 

·
Z06 Tech Advisor
Joined
·
1,870 Posts
Your tuner should have been able to debug the problem and find what was wrong

Could be a leaking fuel injector, a O-ring of one of them

Best is, you could buy from an auto parts store a special dye that you put in the gas that then glows when wearing special glasses sold with the dye such as looking at the injectors mounted into the fuel rail or the other end into the intake manifold
Maybe this engine was worked on or injectors changed, and they ruined a O-ring when putting injectors back on
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Your tuner should have been able to debug the problem and find what was wrong

Could be a leaking fuel injector, a O-ring of one of them

Best is, you could buy from an auto parts store a special dye that you put in the gas that then glows when wearing special glasses sold with the dye such as looking at the injectors mounted into the fuel rail or the other end into the intake manifold
Maybe this engine was worked on or injectors changed, and they ruined a O-ring when putting injectors back on
I can push the start button in for 4 seconds without trying to start it and let the fuel pump pull up fuel and it will start correctly every time.
 
1 - 3 of 3 Posts
Top