Corvette Z06 Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
239 Posts
Discussion Starter · #1 ·
Hey

I got my Borla Stingers a while ago and noticed that there was a backfiring sound when I let off the gas. It only lasts for a few seconds and the engine continues to slow down revs. I got the LG headers with Random Tech cats and the noise is still there. I love the noise I get out of my set-up now, but the backfire sound is different and is anoying. People are always asking me if I need a tune up. This has been going on for a while and I have just gotten used to it. But seeing how I am bored at the moment I thought I would post this to see if anyone has this problem also or knows how to fix it. If not oh well I have gone this far with it already. I asked a mechanic that I have gone to in the past and he said it is just because of the free flow nature of the exhaust system. Normal mufflers are more restrictive and hide this sound, but becuase I want high flow and little restriction I also inherit this sound. What do you guys think. Thanks in advance for any replies!

-David
 

·
Registered
Joined
·
6,083 Posts
Mine does it too and I like it. My little 4 banger does it as well...but IT only sounds like mini kernels popping. :lol:


*edit* Mine is NOT a backfiring sound...just some crackeling/light popping upon decelleration. I have no sparkplug etc. issues...it runs like a scalded dog. :jammin:
 

·
Registered
Joined
·
17,744 Posts
The (popping) sound is normal (unfortunately) :z:



.
 

·
Registered
Joined
·
6,149 Posts
Mine did it too, but it was due to misfire from spark plug. Check to see that all your plug wires are on tightly. If you get an engine misfire detected code, it may be cracked sparkplug from the header install. TRUST ME! I Know. Try getting on your car HARD! If your engine hits what FEELS like a rev limiter at high rpms at wide open throttle, but you are NOT AT REDLINE, then it may just be a cracked sparkplug like mine was. It was backfiring and hitting what I "thought" was rev limiter. Basically, the fuel isn't being burnt or something. Check plugs on tight. Then check to see if your car hits what appears to be rev limiter prior to redline. You will KNOW if you nail it, and at certain RPMs it wan'ts to bog down. That was the most expensive spark plug I ever bought to include the labor to diagnose my car. Check it out....
 

·
Registered
Joined
·
8,152 Posts
Some popping is normal. A loud backfire could mean something else. Have you checked your plugs and wires lately? If you think they're okay then I wouldn't worry about the sound.

Alex
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #6 ·
When installing the headers I cracked some of the plugs and wires. I therefore replaced all of my plugs and wires then. I guess that I should recheck to make sure all the plugs are seated properly. Occasionally I have gotten an "engine misfire" code on the dash, but it has been random when it comes on and never comes on twice in a row. Maybe the two problems could be related. What do you guys think if they are seated properly replace them to see if that is a problem (especially because I have gotten a code). When I replaced them after the header install I used OEM maybe I should try aftermarket. Any advice?
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #7 ·
If the plugs or wires are a problem then why does the popping sound only happen under deceleration.
 

·
Registered
Joined
·
17,744 Posts
So tell us is it popping or a loud backfire? Even a completely stock Z06 pops and crackles on decel. :z:
 

·
Registered
Joined
·
1,391 Posts
I think the sound was engineered into the car to scare off
Evo's. :rofl:
But that is another thread....
 

·
Registered
Joined
·
8,152 Posts
scotts said:
I think the sound was engineered into the car to scare off
Evo's. :rofl:
But that is another thread....
:lol: :lol: :cheers:
 

·
Registered
Joined
·
6,149 Posts
dezballs69 said:
When installing the headers I cracked some of the plugs and wires. I therefore replaced all of my plugs and wires then. I guess that I should recheck to make sure all the plugs are seated properly. Occasionally I have gotten an "engine misfire" code on the dash, but it has been random when it comes on and never comes on twice in a row. Maybe the two problems could be related. What do you guys think if they are seated properly replace them to see if that is a problem (especially because I have gotten a code). When I replaced them after the header install I used OEM maybe I should try aftermarket. Any advice?
ENGINE MISFIRE DETECTED means cracked sparkplug. That is exactly what I had. Even if there is a slight hairline crack, it will pick it up under certain high throttle demands. I had same code, it was ENGINE MISFIRE DETECTED and it wound up being a cracked #2 spark plug.....Take to someone to pull plugs and check. It cost me a bit because I dont know crap, but they found a cracked sparkplug from header install.
 

·
Registered
Joined
·
361 Posts
Oh man, that's why i GOT Stingers :jawdrop:

Mine too is not a backfire(as in loud firecracker) sound. it's just a belching/popping sound of the excess exhaust gases flowing out when you lift. it is just so cool. You may have a problem if it's a loud backfire.

I have so many people tell me that the car sounds really, really mean and racey. I tell you, when you lift, it sounds exactly like the turbo V-8's the Indy cars used to use back when they had real engines in them :lol:

Stingers rule :thumb:
 

·
Registered
Joined
·
4,542 Posts
My '02 had what I believe is the same sound you are having. I described it as a "rattling in a tin can" sound & it was very brief but annoying until you got used to it.

I never put one on mine but have heard the X-pipe will help the situation.

:jammin:
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #15 ·
Ya I would say that it is a loud backfire. It does kind of pop though and I did not hear the noise with the stock exhaust.
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #16 ·
I guess i'll either have to shell out the $$$ for an X-pipe or live with it. Thanks guys for the input!
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #17 ·

·
Registered
Joined
·
61 Posts
I get the off rev "burble" with a stock exhaust and I like it. I also get another odd sound. The best I can describe it is if you got a foot long metal pipe, filled it with cement and let it dry, then took several bangles/metal bracelets off of a girls wrist and put them in the center of the pipe, then holding both ends, shake the pipe. A one-word description, "jangle" ? Not loud, you have to listen for it, but it's there. No codes, no performance problems.
 

·
Registered
Joined
·
17,744 Posts
dezballs69 said:
I guess i'll either have to shell out the $$$ for an X-pipe or live with it. Thanks guys for the input!
Whoa, If you have LG longtubes you already have a X-pipe :z:
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #20 ·
Aren't there two forms of LG headers? 1)The off road version with the X-pipe. 2) Street legal metal matrix random tech cats. I have the second with the cats and I thought it did not have an X-pipe. Man I feel really dumb right about now.
 
1 - 20 of 30 Posts
Top