Corvette Z06 Forum banner
1 - 20 of 46 Posts

·
Registered
Joined
·
1,423 Posts
Discussion Starter · #1 ·
Well, it happened this morning at 2 yrs and 6 months and 14,000 miles. I had the Z in to install the column lock bypass. I've been watching the problems detailed on the Forum about the OEM battery and the Optima Red Tops. I have also paid close attention to the charging system. Always charging 13. to 14.1 on DIC. Started up this morning no problem. Drove to Firestone and shut off. No problem. The manager, my buddy, moved his truck and said I should park it in his spot. Started up no problem. The only tech permitted to touch the Z starts it up no problem. He backs out and shifts to 1st - car shuts off and the DIC is flashing Security. No warning at all. Just busted. I was going to wait until fall, but I'm just lucky I was in the Firestone parking lot and not 100 miles from nowhere in eastern Montana. I even went home to get the second set of keys after reading the Manual. However, nothing wrong but the battery. All this on a car that is driven year round. If it sits longer than a week in the winter, I put a battery tender on it. I think I did all the right stuff and kept an eye out for trouble, but it happened anyway. If your OEM battery is more than 2 and a half years old, get a new one. Don't wait because yours could also go without warning.
 

·
Registered
Joined
·
2,018 Posts
Pretty typical. Mine went the same way. You post probably should say "will go" instead of "could go" the same way.
 

·
Registered
Joined
·
1,474 Posts
I'll be sure to keep an eye on that. I think I'm going to upgrade to a Optima Yellow Top
 

·
Registered
Joined
·
226 Posts
Mine died at a FORD car lot. They all got a big kick out of it. A lot of good natured ribbing. They were still dying for me to trade it in, so they didn't think too bad of it.
I was looking at Explorers for the wife. My vette is not going anywhere!
 

·
Registered
Joined
·
5,333 Posts
So...at 3 years 8 months on the OEM battery...it's time??

Charlie
 

·
Registered
Joined
·
1,580 Posts
NYCHASM said:
So...at 3 years 8 months on the OEM battery...it's time??

Charlie
:yeadog:
I changed mine out a little over 2 years.....prior GM experience taught me that OEM batteries are one of the weakest links
 

·
Registered
Joined
·
373 Posts
Not that this may matter but the basic warranty 3 year/ or 36,000 mile should cover (at least partially) the batteryc. I assume you replaced the battery already. So in that case you can press your case with the nearest dealer or fill out the Chevrolet reimbursement forms.

Mine broke down at app the 4.25 year mark, so nada for me. :puke:
 

·
Registered
Joined
·
198 Posts
mine died on me two weeks ago. its was the original battery in my 02. I was in the staging lanes at my local 1/4 mile track and when our lane started to go I went to turn the car on and I got nothing. No lights what so ever. I had to have a camaro jump me and then I had to drive to walmart as it was 11pm at night and the only thing open. The car didnt even want to pull the head lights up it was so weak even just running on the alternator.
 

·
Registered
Joined
·
8,152 Posts
Good advice. My battery is about two years old now. I will buy a new Optima Red Top soon.

*knock on wood*

Alex
 

·
Registered
Joined
·
5,333 Posts
OK! You guys talked me into it. I guess I'm really pushing my luck at 3 years PLUS!! Since it looks like these things just die with no warning, it's time to head over to Sears for their best Die Hard.

Charlie
 

·
Registered
Joined
·
1,575 Posts
I'm at 3 years and 10 months and I don't use a battery tender in the winter. I think a new red top is coming in the spring. :yeadog:
 

·
Registered
Joined
·
5,754 Posts
My battery is original an will be 4 yo next week..................no trouble so far. Optima Red Top on my list of things to get.

I just realized that I had my Z06 since Aug 22 2001! Her birthday is coming up and I didn't bake a cake, but I will get her a Red Top as a present. :cool:
 

·
Registered
Joined
·
5,333 Posts
I'd buy a Red Top but all that pretty red would be wasted as the I/C reservoir sits on top of the battery. :(

Charlie
 

·
Registered
Joined
·
3,817 Posts
I guess I'm in the same boat with the car built in Oct. '02. I have heard so many horror stories about the Optima Red Tops failing and not holding a charge....I'm going to spend the extra few dollars and get the Odyssey. :idea: Nothing but the best for the Z! :thumb:

Bob :D
 

·
Registered
Joined
·
11 Posts
Mine Dies too

i have a 03 MY with 4700 miles. If I dont start the car at least weekly, the "charge system fault light comes on. The battery has had to be charged twice now. Sounds like time for a new battery. :flaming:
 

·
Registered
Joined
·
1,474 Posts
just to throw this out there...you could also get a Dyna Batt. Weighs about 13.5 lbs and works really well.
 

·
Registered
Joined
·
85 Posts
About 3.5 yrs and 41k miles and still going on the OEM battery. Of course it sporadically says Charge System Fault on startup. But it's done that since new.
 
1 - 20 of 46 Posts
Top