Corvette Z06 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I am baffled by this annoying belt squeal that I have going on. I run a gates 6 rib on a A&A V2 kit. I also have the Innovators west (8 rib) balancer. the car sat for the winter, I changed the starter, alternator, fired it up for the summer. I went to Watkins Glen for a little track play time, and it ran great. The other day, I started it and it came back....the dam squeal.. Its consistent with rpm increase and decrease. at idle its quiet. When I spray the water pump pulley with wd40 it gets quiet. Im wondering if the smoothness of the water pump pulley and the gates belt....I don't know...All the tensioners are tight, don't seem to be any play in them. Belts new also.
 

·
Administrator
Joined
·
21,250 Posts
I'm not as familiar with the Vortech blower as I am with the Procharger, but depending on the amount of boost you run, the water pump pulley can be a weak spot. It can actually bend a little allowing belt slip and squeal. At one point, we had to weld on a support bridge to keep the pulley from bending down a little under stress.
May not be the issue but most belt squeal comes from slippage at some pulley point.

Mike
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Im only running 6-8lbs of boost. It sounds like the water pump area is where the sound is coming from. but whats odd is its at idle and goes up, so belt stress is minimal at those rpm levels. Maybe I glazed the belt and the smooth spots (like the water pump) are whats doing it.... I dunno
 
1 - 3 of 3 Posts
Top