Corvette Z06 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
So, I take the Z out to dinner tonight and when I get back in to come home, the interior lights don't come on, the gauge lights sort of flicker, and when I try to start, everything goes dark. I don't know if this is caused by the HID conversion (GM Euro Headlamps and Blinglights H4 conversion) but that's the only thing that I can think of that I might have done. The conversion has been on there for about four months or so and the car has been driven about four thousand miles in that time period without any problem like this. There is also a strange sound coming from the fuse block next to the battery that I think is related to the problem. Has anyone else had this problem??? Advice is absolutely welcomed!
Joe
 

·
Registered
Joined
·
844 Posts
Bfore you start ripping the car apart--have you checked the battery. Sorry if this sounds like a dumb question but the symptoms you describe I have heard before.
 

·
Registered
Joined
·
17,744 Posts
I agree, the battery has gone south. :cheers:
 

·
Registered
Joined
·
882 Posts
Have to agree. My 03 battery was just starting to act "funny." Would take a charge but with just a little usage, it would go "click." Gone are the days when a battery would last 5 years or so. With the heavier usage of electronics, the situation is even worse. :)
 

·
Registered
Joined
·
4,384 Posts
Change the battery first... knock on wood mine has been great for the two years I've owned the car and is the original one from the factory. But then again I drive my car 4-5 times a week.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #7 ·
Thanks for the help, I'll try putting in one of my spare batteries and seeing if it helps.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #8 ·
Well, I got an Optima red top, $130, and fixed the problem completely. Even better, took the Z with the new battery installed, along with the original battery and receipt for the Optima to the chevy dealership, and they reimbursed me for the complete $130. Not too bad.....

Cobra4B, I drive mine just about every day, had it since April of '03 and have 25,000 miles on it now, so I don't know why it went bad, but knock on lots of wood!
 
1 - 8 of 8 Posts
Top