Corvette Z06 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
457 Posts
Discussion Starter #1
ELF, how many miles on the car?
Neither my Z06 or my 98 C-5 brakes pull to one side or the other. Did you break them in gently?

Any other members comments ???




------------------
 

·
Registered
Joined
·
299 Posts
Am I seeing something normal or unusual with the brakes? First time I hit the pedal the car may pull to the left or the right. after that it doen"t seem to do it. When it does happen it not a strong pull but enough to let you know.


------------------
 

·
Registered
Joined
·
566 Posts
This is pretty normal. My 97 used to do it, too. Once the brakes get warm, they should pull evenly. It was most noticable during light breaking. BTW, welcome to the forum.


------------------


Quicksilver Z06

[This message has been edited by Dennis Jurs (edited 02-09-2001).]
 

·
Registered
Joined
·
576 Posts
I have not had any pulling of the brakes in the first 2000 miles.

GOLD72

------------------
 

·
Registered
Joined
·
457 Posts
Discussion Starter #6
<BLOCKQUOTE>quote:</font><HR>Originally posted by N4C5S:
Mine were a little grabby at first, now they're just fucked.

I have hot spots all over both front rotors and if you pull the e-brake at speed it growls horribly.

JC
<HR></BLOCKQUOTE>

WOW,kinda says it all


------------------
 

·
Registered
Joined
·
12 Posts
This used to happen to me with my 00 coupe. It hasn't happened with the Z yet. Not to worry........


QUOTE]Originally posted by ELF Z06:
Am I seeing something normal or unusual with the brakes? First time I hit the pedal the car may pull to the left or the right. after that it doen"t seem to do it. When it does happen it not a strong pull but enough to let you know.


[/QUOTE]



------------------
01,Z06,spdwy white.
 

·
Registered
Joined
·
9,411 Posts
Mine were a little grabby at first, now they're just fucked.

I have hot spots all over both front rotors and if you pull the e-brake at speed it growls horribly.

JC
 

·
Registered
Joined
·
219 Posts
1800 miles - no problemo other then brake dust!

------------------
QS/Black - Stock Z06
99 Z28
70 LT-1 T-Top
70 Z28 RS
Amish Buggy (1 H.P.)
 

·
Registered
Joined
·
105 Posts
You might check with Ken Fichtner's page, the Corvette Forum, and ask him about factory warrenty problems!
He is well in the know, and might can advise you better.

If all else faile check out Ken's page for the "C5R" rotors and pads or new ceramic pads.


------------------
Meillennium Yellow with alloptions,B&M ripper,C.L.bypass,Air Rammer,TBB,and more comming in.

[This message has been edited by ZO6Bill (edited 02-14-2001).]
 

·
Registered
Joined
·
2,459 Posts
Hot spots, warppage, you name it. Dealer turned the rotors at 6k miles, they're starting to warp again at 11k. I tried to get them to replace the rotors and pads, but Chevrolet refused. Anyone have any ideas?

------------------
 
1 - 11 of 11 Posts
Top