Corvette Z06 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
449 Posts
Discussion Starter #1
Wondering if anyone is aware of a slight vibration/pulsation in the front of the car when braking normally. It happens when slowing down between for the short period between about 14 mph and 12. I saw someone else mention the same symptom but have heard no technical reason. Wheel lugs are tight and it doesn't seem to be an anti-lock brake issue.
 

·
Registered
Joined
·
218 Posts
constren said:
Wondering if anyone is aware of a slight vibration/pulsation in the front of the car when braking normally. It happens when slowing down between for the short period between about 14 mph and 12. I saw someone else mention the same symptom but have heard no technical reason. Wheel lugs are tight and it doesn't seem to be an anti-lock brake issue.
Mine's done it since day one. Initially the pedal was very soft before break-in. After some hard driving the pedal became firm. Now with 4,000 miles on the car it still does it, yet the rotors aren't warped or cracked or anything. Yet there's still that hint of slight vibration at that exact speed you mention -- and ONLY at that speed. And NEVER at any other speed, even braking at 140+MPH. I just got used to it as a quirk of the car.

Andi
 

·
Registered
Joined
·
449 Posts
Discussion Starter #6
I'm thinking this may be a problem others have after reading on another forum it affected someone else. Just wondering how many have it and what the hell it is. It's so subtle that I wonder if others have it and just haven't noticed. Don't want to bring it to the dealer but hoping someone has and can disclose what it was just to determine if it requires attention.
 

·
Registered
Joined
·
218 Posts
allanlaw said:
What if the car is just rolling (no brakes, no gas) at that speed?
It's only a braking vibration and it is felt through the pedal. It almost feels like a very slight ABS pulsation or something. At exactly the MPH's he mentioned. Every time. Maybe a resonance between the padlets and the holes in the rotors or something, who knows.....
 

·
Registered
Joined
·
218 Posts
constren said:
I'm thinking this may be a problem others have after reading on another forum it affected someone else. Just wondering how many have it and what the hell it is. It's so subtle that I wonder if others have it and just haven't noticed. Don't want to bring it to the dealer but hoping someone has and can disclose what it was just to determine if it requires attention.
I might be that someone else, btw....

posted last month.....
http://forums.corvetteforum.com/showpost.php?p=1554368681
http://forums.corvetteforum.com/showpost.php?p=1554379879
 

·
Registered
Joined
·
203 Posts
Mine did it for about 100 miles then stopped. I thought it was because I tracked it early and then the brakes finally bedded. Everything fine now. You might want toi give it awhile.
 

·
Registered
Joined
·
449 Posts
Discussion Starter #12
RFC2 said:
Mine did it for about 100 miles then stopped. I thought it was because I tracked it early and then the brakes finally bedded. Everything fine now. You might want toi give it awhile.

Got 600+ miles on it. Maybe needs a bit more punishment!:pp:
 

·
Registered
Joined
·
351 Posts
Andi said:
It's only a braking vibration and it is felt through the pedal. It almost feels like a very slight ABS pulsation or something. At exactly the MPH's he mentioned. Every time. Maybe a resonance between the padlets and the holes in the rotors or something, who knows.....
Maybe the padlets and the pins that hold them are doing something naughty at that precise point - strange, like my possessed air conditioner controls . . .
 
1 - 13 of 13 Posts
Top