Corvette Z06 Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
239 Posts
Discussion Starter · #1 ·
Hey Ya'll

Every once and a while when I start up the Z it says "Charge System Fail" on the instrument panel. This seems to happen every once and a while and I can not find any kind of pattern to predicte when it will happen. Yesterday it did not throw "Charge System Fail" but it kind of balked and turned over slow before actually starting. Any ideas are appreciated thanks!

David
 

·
Registered
Joined
·
806 Posts
:mug: I have had this happen a few times also. It seems to happen when the car has not been driven in a few days. The best way I have found to avoid this is when you are about to start her up, turn the key to the ON position and wait for the "Corvette By Chevrolet" and all the guages to settle. Then start her up, and all should be fine. I think everyone has seen this once or twice but I don't think it is anything to worry about as long as it goes away after you start the car. Try this out and see how it works, If you still get it you may have something more serious going on and may need to take it in. Good Luck! :cheers:
 

·
Registered
Joined
·
1,465 Posts
It means your battery voltage is low which could be due to the charging system, but usually is just a problem with the car sitting too long (all of the electronics drain the battery while the car sits) or the battery needing replacement. The original AGM batteries suck.

If you don't drive your car often, the best thing to do is to get a battery tender and leave it hooked up while the car is not in use.
 

·
Registered
Joined
·
17,744 Posts
In my vette when I turn the key on the gauges go all the way up and back while the DIC says "Corvette by Chevrolet". I always wait until the DIC is done and the gauges have returned to the starting point to start the car. I never get the charge system fault when I do that. :cheers:
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #5 ·
Thanks ya'll for the advice. I'll try waiting till the instrument panel is done saying "Corvette by Chevrolet". Thanks!
 

·
Registered
Joined
·
3,212 Posts
dezballs69 said:
Thanks ya'll for the advice. I'll try waiting till the instrument panel is done saying "Corvette by Chevrolet". Thanks!
You can wait, but one has nothing to do with the other.

I don't know exactly what criteria the computer uses to issue the charge system fault message, there are a few possibilities. But it is unquestionably related to measured voltage at startup. If I had to guess, if I'd been the GM engineer designing it, I'd record the voltage at shutdown and compare it to the voltage at startup and issue the message if there was a big difference.

Curiously, the obvious criteria would be that the system isn't charging, but that doesn't appear to light the light. I've thrown my belt a couple of times (need an 8-rib for my supercharger) and the "Charge System Fault" message doesn't come up even when the Alternator isn't turning!

I get a CSF message intermittently, and have since the car was new. The power system on the C5 seems marginal to me (we've all observed the random headlight flicker). I suspect that if the "right" load conditions are present at either the last shutdown or the next startup, the computer gets fooled in to thinking there's a problem, since in spite of numerous, sometimes extended, periods of non-op (2+ weeks) I've never had a cranking problem.

Of course, that doesn't mean you really don't have a problem...
 

·
Registered
Joined
·
239 Posts
Discussion Starter · #7 ·
I get what your saying, but is there a fix to it. Is the power system just a POS that I will have to live with. If there is a bigger issue what could it be?
 

·
Registered
Joined
·
17,744 Posts
dezballs69 said:
I get what your saying, but is there a fix to it. Is the power system just a POS that I will have to live with. If there is a bigger issue what could it be?
Did you have a chance to try my idea? :cheers:
 

·
Registered
Joined
·
3,166 Posts
ITL GO,

What makes you think that by waiting until the DIC is done with its startup ritual, the CSF message won't appear. Is there some tid bit of info you know about that could help here? Usually your info is sound, but Rocketsled is making me doubt you here. Master of minutia, show us the light. :D
 

·
Registered
Joined
·
17,744 Posts
Zrod said:
ITL GO,

What makes you think that by waiting until the DIC is done with its startup ritual, the CSF message won't appear. Is there some tid bit of info you know about that could help here? Usually your info is sound, but Rocketsled is making me doubt you here. Master of minutia, show us the light. :D
I'll yield to the King aka Rocketsled. All I know is that it was suggested it for me to try when I was getting Charge Faults and it has worked for me. Some folks seem to never get the faults and I for one got a lot of them. Since I have went to the wait method I have not got any. Go Figure. :)
 
1 - 10 of 10 Posts
Top