Corvette Z06 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
After the trip home from the dealership and a couple trips around the city (1800 miles), I thought it may help break-in to change to conventional motor oil. I put in Pennzoil 10w30 in. I am going to run around with this oil for a couple of weeks. I guess in my mind some of the oil consumption problem reported by early Z06 owners can be attributed to breaking in on synthetic oil.

Any feedback from similarly anal owners? /phpBB/images/smiles/icon_confused.gif

By the way, jacking these cars up is a pain!
 

·
Registered
Joined
·
0 Posts
I specifically asked Katech Engines about switching over to regular oil instead of synthetic. Their answer was they use synthethic to break in all their engines. They said there was no advantage to switching to regular oil.

If anyone knows, they do!! /phpBB/images/smiles/icon_smile.gif If it's good enough for the C5R engine, then its good enough for me!!
 

·
Registered
Joined
·
226 Posts
Discussion Starter #3
Thanks for the feedback. I too would trust Katech. I guess times, they are a changing!
 

·
Registered
Joined
·
171 Posts
The oil consumption problem has nothing to do with break-in or rings not seating.

Switching to petroleum-based oil after using synthetic will not fix anything.

If the engine is using more than about a qt. every 1000 miles and the engine has 2500 or more miles on it, I'd take the car to the dealer, tell them it's using oil and ask for the ring fix.
 

·
Registered
Joined
·
1,248 Posts
Hi there,
Absolutely, doNOT use conventional oil in Gen3 engines. Hib is on his game.
Katech, also is correct here, as the consumption has to do with technical reasons with piston ring pumping loses, NOT break in.
Just thought I would .02 this one, as there has been alot of talk on the LS1 board about this.
Best to you, c4c5
 
1 - 5 of 5 Posts
Top