Corvette Z06 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter · #1 ·
alright guys i have a 2002 Z06, shes got 60k miles (i know its high :( ) i dont think the clutch has ever been replaced..

here is the problem.. the other day im driving along and go to downshift into 2nd.. i push the clutch in all the way and go from 3-2 and it starts grinding.. this is with the clutch pushed in.. it did ti about 4 times that day and has not done it since... is that because the clutch is not fully disengaging??? or is the tranny jacked up ??

the next problem is my clutch pedal... for it to grab the pedal has to be ALL the way out.. like i have NO pedal left to let out and it finally grabs.. from what i have heard from all of you your pedals are all close to the ground?? im guessing its time for a new clutch as its also slipping just a little bit... any suggestions or advice are much appreciated... thanks in advance!
 

·
Registered
Joined
·
2,127 Posts
1-Clutch is worn out
2- might have a bad blocker ring in second, Slipping clutch will not cause grinding but a warped disc will.
 

·
Registered
Joined
·
86 Posts
The blocking rings are essentially "wear items". A worn ring, or wearing ring, will manifest itself just like that (works fine under normal shifting, will grind at high rpm/quick shifts). In the synchro assembly, the rings are the friction elements that actually do the speeding up/slowing down to synchronize the the speed of the gear clutch teeth and the synchro clutch teeth.
 
1 - 11 of 11 Posts
Top