Corvette Z06 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,798 Posts
Discussion Starter #1
Coming home from Bowling Green on the interstate and the car started misfiring and jerking. I thought that from the way it was shaking I might have a flat, but it didn't. The check engine light came on. It was blowing out white smoke from the middle two exhaust pipes. I had just filled it up with Exxon, so I thought it might be bad gas. When I got home, I filled it up with Sunoco (my usual gas) and added a bottle of octane boost. The check engine light went out. Today, my buddy put it on the computer and these two codes came up
200 Low voltage to the fuel injector
300 Engine misfire detected.
Anybody ever have this happen to them and what was the fix?
HELP PLEASE

2002 Z
 

·
Registered
Joined
·
230 Posts
Interprep Performance Tuning 112 Harrison St. Jamestown, NY (716)483-6287. Alistair Oag is the man to help you. I think he'll be at Mosport this weekend, but he does work on Saturdays. Tell him the guy in the black Z06 from Westfield sent you. Good luck.
 

·
Registered
Joined
·
892 Posts
White smoke is a little weird - that's usually an indication of coolant leaking into the combustion chamber, most often due to a blown head gasket. But that doesn't coincide with the error codes you got.

Maybe check the fuel injector wiring harness - a common problem with C5's is the harness may chafe near the firewall, and one or more of the fuel injector wires will short out, causing a fuel injector to not work right.
 

·
Registered
Joined
·
6 Posts
Actually.....

The white smoke is common. I have seen it. Actually, sometimes it is raw fuel that is vaporized like water and looks white. One of your fule injectors could be clogged or stuck in the open position. I am sending fuel injectors off tomorrow to Marren and they will let me know if the FIs are screwed. If not, they will clean and balance the injectors and send them back.
 
1 - 4 of 4 Posts
Top