Corvette Z06 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
Yesterday while driving my '02 Z the CEL came on. All temps and oil pressure normal, nothing obvious amiss under the hood, and gas cap secure. Cycled the engine a few times to see if the light would go off but it stayed on. Drove it home and let it sit in the garage. This morning I went to check the codes on the DIC. Here's what came up (engine cold):
A1-RDCM
B2283H
B2285H
U1064H

10-PCM
P0171H
P0174H

A0-LDCM
B2282H
B2284H

I reset, cleared the codes, and fired her up for a run into town. No check engine light until the oil temp got into the 180's and I accelerated at what I would describe as moderately aggressive (4 thousandish RPM). Come to think about it, yesterday the check engine light also came on when I also accelerated fairly hard (to about 5K RPM). Again all temps and pressure appeared otherwise normal.
The CEL stayed on until I got home. Shut her down and then checked codes. Identical as before except for the PCM; this time it did not show the P0171H code, just the P0174H code.
I looked up what these mean. I have no clue to what the Battery #1 Circuit and Battery #2 Circuit refers (B2282 and B2283, and B2284 and B2285, respectively). P0174 (and P0171) refer to Fuel Trim System Lean. I have a Halltech TRAP intake on the car; that and a custom catback exhaust, but otherwise car is stock. The TRAP has been on since last summer, and never threw a code before. I seem to recall some folks saying their TRAP threw a code when they first installed it, but as I said, I've had mine on for awhile without any problems. I'll need to check to make sure all the intake connections are tight. Battery is the original AGM (3 years old) and the car's voltmeter showed upper 13- low 14 volts.
So that's the story. Thoughts and advice? If I take it to the dealer, while he's pretty reasonable, I'm assuming he'll say I need to replace the stock air intake, to see if the P0174 (or P0171) code returns. Otherwise, would this mean I need to get an LS1Edit to alter the fuel/air mix? Thanks everyone for your help.
 

·
Registered
Joined
·
3,212 Posts
The only codes that matter for this are the P0171 and 0174 codes. The RDCM and LDCM codes are common/not-unusual.

The too-lean codes are common with aftermarket intakes. In all probability you are running rich at WOT and the intake is actually hurting performance, not helping.

You need to either tune the car, install a MAF-tricker, install larger Injectors, or take the intake off.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #3 ·
RocketSled,
Thank you for your reply. Any thoughts as to why the lean codes would start to appear a year and a few thousand miles after the TRAP installation? This was the first time it ever threw a code.
 

·
Registered
Joined
·
1,089 Posts
all your codes have H on them so that means they are histroy not current. All current codes will have a C after the H. or just a C if this is happening the first time or some.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #5 ·
Kool,
I understand the C versus H coding; maybe I'm not understanding the import. I'm assuming that what is happening is that this is a momentary occurrence, but significant enough to trigger the code. Hence when I pull the codes later, it is showing the "H"?
I'm thinking this is also what happened after I pulled the codes the first time, cleared them, and then went for a drive. It again momentarily hiccuped and threw a code, which then subsequently showed up as an "H" designation, but since it wasn't an ongoing or continuous occurrence, it didn't show as a "C" event. Yes, or am I missing something?
 

·
Registered
Joined
·
42 Posts
THats funny. I have the same codes as you. My CEL just came on yesterday for the first time. Have around 2,000 miles on my Z06 since the Halltech install. All of mine were History codes also. I just cleared them last night.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #7 ·
JeffRM said:
THats funny. I have the same codes as you. My CEL just came on yesterday for the first time. Have around 2,000 miles on my Z06 since the Halltech install. All of mine were History codes also. I just cleared them last night.
Jeff,
Do you literally mean ALL THE SAME ???
:-? Weird....
 

·
Registered
Joined
·
1,071 Posts
I have been having this problem for a long time. Jim Hall told me to get a different MAF and the problem will be gone. The problem now seems to be happening more often with the install of my LG headers (more air). Have you guys been able to eliminate the check engine light?
 
1 - 9 of 9 Posts
Top