Corvette Z06 Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
345 Posts
Discussion Starter · #1 ·
The dealer finally called yesterday and I picked her up at 5:00 pm.Sweeeet,electron blue absolutely beautiful and in perfect condition.Ok,here we go.My wife followed me home which is about 10 miles from dealer.She jumps in for maiden voyage.I opened it up a little on highway and scared her to death.Don't get me wrong,I didn't hammer it,just eased on throttle.It took off like a rocket.About 10 minutes into our ride it began to rain,so I flipped on the wipers....and then it happened.The washer cap on end of wipers popped off sending cap,springs and who knows what else flying in my wife's lap!!! When this happens,washer fluid squirts and wipers run... and run ...and I can't shut them off.After about 2 minutes I run out of washer fluid, I pull over, gather up the pieces,and try putting them back together to no avail.I whip out the manual.Fortunately by this time it has quit raining.I figure out where the fuse is,pull it [so I don't burn up washer motor] and haul ass home before it starts raining again.I took it to dealer this morning and they didn't have part,They, have to over nite it from Atlanta so i get a rental.Now here I sit talking to ya'll.But that was the best damn 42 miles i've ever driven.
 
G

·
Congrats!

If that is the worst of your problems, you are doing great!

The washer guy must have been on a smoke break during your car's build?
 

·
Registered
Joined
·
345 Posts
I'm going to check that on mine this AM. Thanks for the heads up. Sorry you had this happen.:(
 

·
Registered
Joined
·
76 Posts
Damn, sounds like a small problem, but I'd be pissed!! :mad:
Hope you're back in the driver's seat soon.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top