Corvette Z06 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter · #1 ·
I am in the middle of my lgm pro long tube install and while taking off the stock H pipe i noticed the wires were crosses on the rear o2 sensors. in other words the drivers side o2 was connected to the passenger side connector and the passengerside o2 was connected to the drivers side connector. Is this correct? I have had them off at a shop before so thats why i am asking. Also while I am thinking about it... are the front o2s going to reach the headers since i now have the rear bungs for those 02 sensors? Am I going to have to lengthen the wires or get another set of rear o2 sensors/ any help is appreciated. thanks
John
 

·
Registered
Joined
·
881 Posts
John: The rears do cross, but not the fronts. My SuperMaxx headers came with a set of extenders (for the fronts, I think) and I re-installed all four of the original O2s. The rear wires weren't quite long enough either, but by removing the plastic mounts that retain them against the fender wells I was able to get the extra length I needed. Just be careful to route and retain the wires so they cannot touch the headers anywhere. If you search this forum, you will find a great post about picking up these little metal clips at Home Depot (in the section with small elec. parts, lugs, hand tools, etc) that are covered in black rubber. These have a hole in them and can be mounted on the tunnel brace bolts to hold the wires up and away from the headers and collectors on the way to the rear O2s. HTH. If you need more help, PM me and I'll send you my phone number.
 

·
Registered
Joined
·
1,827 Posts
I don't know if you have the LGMs with 4 O2 bungs or 2. Mine only had two, and the set came with adapters to lengthen the factory O2s to reach these. You have to hook them up left to left, and so on. Yes, it's opposite of the factory set-up. If you don't have these adapters, or have the 4 bungs, please disregard. Good luck. I'll add this. I had to get a set of O2 sims, which plugged into the original rear plug, and the adapter, which plugs into the front plugs, and allows your longer O2s to reach the single bungs. You may have the cats, so I don't know how this is set-up.
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #5 ·
thanks for the replies guys, i do have the 4 bung setup but i just blocked off the rear bungs with some old o2 sensors laying around and let the harness on the computer side unplugged. i must say it took me alot longer than expected but after the test drive it was well worth it. The sound is awesome and it definately pulls harder. I was suprised not to see a check engine light on since the rears are unplugged. I will be getting the car tuned on sunday so I am hoping for a little more gain out of it. Thanks alot for your help again guys. :thumb: :z:
 

·
Registered
Joined
·
5,046 Posts
JohnS said:
I was surprised not to see a check engine light on since the rears are unplugged. I will be getting the car tuned on Sunday so I am hoping for a little more gain out of it. Thanks alot for your help again guys. :thumb: :z:
More than likely you will see the check engine light soon. Either have the tuner edit out the back sensors or buy some SIMs to simulate the rear SIMs. The best advise I can give you is to make sure that you have done a good job of routing the wires away from the exhaust pipes. Spending extra time now (and adding a little wire insulation) will prevent the #1 problem people have done the road after installing headers. Good Luck.
 

·
Registered
Joined
·
198 Posts
Discussion Starter · #8 ·
IT L GO said:

i am going to go purchase those and install them today. i am a little uneasy about how my wires are run right now. Also will it hurt the car driving it around for today with no rear 02 until I can get it tuned tomorrow? I dont believe it will but i just want to be sure. i think it will just throw a code and may run a little rich but thats about it. Any opinions on that?
 

·
Registered
Joined
·
881 Posts
JohnS said:
i am going to go purchase those and install them today. i am a little uneasy about how my wires are run right now. Also will it hurt the car driving it around for today with no rear 02 until I can get it tuned tomorrow? I dont believe it will but i just want to be sure. i think it will just throw a code and may run a little rich but thats about it. Any opinions on that?
Won't hurt anything. Go drive the crap out of it! :D
 
1 - 9 of 9 Posts
Top