Corvette Z06 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter · #1 ·
i know several issues with fuel gauge, i just started noticing this. it goes from 1/2 to 3/8 very rapidly then down to 1/4 pretty quick although not as fast as the 1/2 to 3/8 drop. this ticks me off, i think i've got plenty of gas for the week, then bam, my range says less than 100 miles. it's so fast, the first time i noticed i thought i had a leak!i just now, drove about 10 miles and it went from a hair over 1/2 (range 195ish miles) to less to right under 3/8 in about 10 minutes...range 150 miles. this is a common part of all the problems too and an easy fix? or, ah, just live with it and no it does it. i understand the second 1/2 going faster, but 1/2 to 3/8 in 10 minutes. has done this on me 4 times now. thx!

jody
 

·
Registered
Joined
·
476 Posts
I think it has something to do with a double fuel tank with a cross-over!

I remember a thread a while back over this issue!

You may want to do a search in this site!
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #3 ·
yeah i did a couple searches, different combos, either got nothing or a million results. figured it's easier to just ask.
thx!
 

·
Registered
Joined
·
1,131 Posts
The problem is caused by sulfur contamination on the fuel sending unit. The fix is to replace the fuel sender (which requires dropping the gas tank). Since your car is exhibiting the problem, there is a fix that I found a while back that works on SOME cars. Cruise down to your local auto parts store and buy a fuel additive called "B12" (pep boys and autozone both have it). Add a can of it to your tank and fill it with about 10 gallons of gas, then drive the car like you normally would. Try to burn off the whole tank in the span of about a week, and don't refill the car until your almost completely out of gas (low fuel warning). If the problem goes away, then you don't need to replace the fuel sender, and you can consider yourself one of the lucky ones. Myself and a few other members that were having problems with our gas guages have had good luck with this one (my car hasn't had a problem since). I wouldn't recommend using this stuff as a preventive maintenance though as at least one member used it on a car that didn't exhibit the problem and said that it caused the erratic gas guage problem to start on his car. Good luck! :cheers:
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #5 ·
cool, thx. i guess dropping 1/2 to 3/8 in 10 minutes is problem enough then to give this a shot.
car is still under original factory warranty, although i am getting GMPP next week.
thx!
 

·
Registered
Joined
·
329 Posts
Mine did the same thing after 2 straight tanks of Shell , I did the B-12 Chemtool thing & quit using the Shell & no more problems! I think the gas guage showing different readings is the cross over function as well it seems to even out after a few miles I now add a bottle of Techron every 2nd or 3rd tank now.
 

·
Registered
Joined
·
3,014 Posts
slow99 said:
i know several issues with fuel gauge, i just started noticing this. it goes from 1/2 to 3/8 very rapidly then down to 1/4 pretty quick although not as fast as the 1/2 to 3/8 drop. this ticks me off, i think i've got plenty of gas for the week, then bam, my range says less than 100 miles. it's so fast, the first time i noticed i thought i had a leak!i just now, drove about 10 miles and it went from a hair over 1/2 (range 195ish miles) to less to right under 3/8 in about 10 minutes...range 150 miles. this is a common part of all the problems too and an easy fix? or, ah, just live with it and no it does it. i understand the second 1/2 going faster, but 1/2 to 3/8 in 10 minutes. has done this on me 4 times now. thx!

jody
Hey Slow,

Funny you mentioned that, becuase my car has been doing this for the past 3 weeks. Is this a problem with 01's only? Or does this occur in 02+ Z's?
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #8 ·
i have an 02 z, with 23K on it. 21K when i bot it 2 months ago!! man i need that work beater!
 

·
Registered
Joined
·
3 Posts
Just got mine replaced this week under warranty.

Ok.. Here is the deal...
GM knows the problem.. It's some material being eroded off the sensor.
I have a recent service bulletin with it from GM.
It states that there is a definite problem and they have "NEW DESIGNED" sensors coming out to fix this , but currently they have not been released to dealers yet. They have a part number and everything, but it said that for now until they are out to use the original type sensor even though it is expected to fail again.
So... I'd wait a bit and see if the new parts are available b4 going through the hassle. I would have , but did not know till it was all over with.
Hopefully they fail b4 my warranty is up so I can get the new ones! I kept the paperwork just in case not so I can go and fight w/them after my warranty is up about knowingly replacing it waith a known faulty part.
 

·
Registered
Joined
·
1,281 Posts
slow99 said:
cool, thx. i guess dropping 1/2 to 3/8 in 10 minutes is problem enough then to give this a shot.
car is still under original factory warranty, although i am getting GMPP next week.
thx!
If your car is under warranty, take it in. They will replace the sending units. If you do it under the GMPP, you'll have to pay a deductable. I've had mine replaced 4 times. Chevron gas with techron seems to be keeping it from coming back this last time.
 

·
Registered
Joined
·
17,744 Posts
Chevron gas with techron has kept mine problem free so far. :z:
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #12 ·
my GMPP has zero deductible, no worries there. i run chevron 93 at all times, it's all i use, still acts up.
 
1 - 12 of 12 Posts
Top