Corvette Z06 Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
hey guys

the other day I drove my car and it felt much slower compared to before. at first I honestly thought my clutch was slipping for some reason, so I took it to a Chevy dealer and they said everything was fine after doing a ton of tests on it.

it feels as if the car has 200 lb. ft. of torque. there is no power down low. top end seems about the same as before.

it's extremely noticeable because I remember before when I could mash the gas at ANY RPM in 1st or 2nd and get the wheels to immediately spin with the traction control on!

today I nailed the accelerator going 5 mph in 1st gear in Competition mode and I can't even get the wheels to spin!!

driving the car when it was running correctly was downright scary, now it is merely impressive, it feels like it's running at 75% capacity

there has to be a problem, anyone have any ideas?

i always run 93 octane from shell...

I noticed this problem when the only mod on the car was the skip-shift delete, so I know the GHL's I just installed has nothing to do with this
 

·
Registered
Joined
·
17,744 Posts
The only way to fine out is put on a Dyno. :cheers:
 

·
Registered
Joined
·
2,409 Posts
SOTP changes in power are very hard to diagnose on the net.

With all the hot weather we have been having your power WILL be down somewhat, and with the street and tires hot your traction will be up. So the SOTP difference you feel may be 100% weather. PLus, as you ger "used" to the power in a new car (or mod) SOTP does not feel as strong, which is one reason why us horsepower junkies keep adding mods to our cars.

A dyno or 1/4 mile drag strip could tell you how much power yu are making, my advise would be to wait for cool weather and see if your perception changes.

Les
 

·
Registered
Joined
·
49 Posts
Discussion Starter #5
thanks for the replies.

it has been extremely hot recently. i tested it out on a 100+ day and a 80ish day and it felt pretty much the same. i know on hotter days your car will make less power but have better traction, but it doesn't feel like the car hooks up better or is any faster because of the better traction because there seems to be a lack of torque down low.

i guess the first move would be to have it dyno'd at an air conditioned shop ?
 

·
Administrator
Joined
·
21,250 Posts
Hey bro, have you thrown any codes lately?
One way that the Z loses a lot of power is when it goes into 'Reduced Engine Power' mode.

Mine has done that several times, but it may be more common on my set-up since thee DFI and PCM have to cooperate together. Heat can confuse the PCM at times with the amount of air intake at the MAF.

It is highly unlikely that this is your problem since the DIC screen tells you pretty quickly when it has gone into this mode, but checking to see if you've tossed any codes lately is still a good idea.

Mike
 

·
Registered
Joined
·
74 Posts
I Just Bought An 04 About A Month Ago After Selling My 02 Anyway, Took It In For A Baseline Dyno Before The Mods Began And To Make A Long Story Short We Had To Put A New Mass Air On It Before The Dyno Run. Something About High Fuel Trims. I Was Just Thinking I Was Getting Used To The Power But With The New Mass Air On It It Run Like A New Car. So Yes Take It To The Dyno.
 

·
Premium Member
Joined
·
652 Posts
Hot intake temps will pull timing starting at 99 degrees.
What it sounds like to me is that your long term fuel trims are heavy on the positive side and you are dumping fuel in open loop. Most likely you are running very rich.
Do you have a puff of smoke out the tailpipes when you first floor it?
 

·
Registered
Joined
·
2,317 Posts
FRC Tom said:
Hot intake temps will pull timing starting at 99 degrees.
What it sounds like to me is that your long term fuel trims are heavy on the positive side and you are dumping fuel in open loop. Most likely you are running very rich.
Do you have a puff of smoke out the tailpipes when you first floor it?
I did :D


Rob
 

·
Registered
Joined
·
1,265 Posts
SCF,

I'm not far from you, it's been to darn damp and hot for these cars to run right. Give it a couples days and see. If you want to come by on Sunday or Tuesday we can take a look see.

Did you check for any codes?

Ernie
 

·
Registered
Joined
·
49 Posts
Discussion Starter #13
thanks all.

i dont notice any smoke when i first floor it, but im usually concentrating on going in a straight line
when i bought the car with 5,800 miles on it i always noticed black soot accumulating on the stock exhaust tips, either i drove it hard or it's constantly running rich or a combination (probably both)

Ernie - sounds good! i dont have any lights on on the dash, and im not sure if ive thrown any codes as i dont have a scanner (yet)

i'd have to come over on a tuesday around 5:30ish or later
 

·
Registered
Joined
·
49 Posts
Discussion Starter #14
Tom-

I just read "These LTFT values are derived from the Short Term Fuel Trims (STFT) which are instantaneous fuel trend indicators and are given a numeric value with (-) being rich and (+) being lean. "

I unhooked my battery for over 30 minutes on 2 occasions this week, I heard that will erase your STFT values, but it won't erase LTFT values?
 

·
Registered
Joined
·
1,265 Posts
SCF,

I'm in Silver Spring, give me a call, don't now what we can do but at least look at it. 301-236-4744

Ernie
 

·
Registered
Joined
·
722 Posts
My $.02- it's the heat...I noticed it right away when I got on the road to the Fest...lots of folks commenting on this right now... :guiness:
 

·
Registered
Joined
·
291 Posts
Hate to chime in here witht he same old stuff but mine is down too. I know it is the heat here. My buddy and I are going over to Orlando tonight and both of our cars earlier today felt like nissan maximas....they were slow, very slow. Keep in mind though, if your car is running slow so is the other one. RACE STILL ON. Just kidding. Good luck, Dr.Bigg :cheers:
 

·
Registered
Joined
·
49 Posts
Discussion Starter #18
hahah...

thanks guys. i didn't realize the heat would be such a big factor that it would make my car from being able to spin the wheels through 2nd with traction control on to not being able to spin them in 1st gear @ 5mph in competition mode!!

i wait for winter.
 
1 - 18 of 18 Posts
Top