Corvette Z06 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
396 Posts
Discussion Starter #1
I just got this thing last week. Quicksilver 3000 miles. Runs like a bat out of hell. Love the car. The car makes a clicking noise like a throwout bearing going bad, but only does it every couple of days. GM dealer said all the 6spd do this but sometimes its pretty damn noisy. anyone else have this problem. Also I am looking into a cam shaft, anyone tried anything, recomendations. With the flow numbers these heads have i think they are way under cammed.

Thanks for the info

PS has anyone figured out if thier is a number sequence to the Z06s.
Thanks again
 

·
Registered
Joined
·
1,248 Posts
Hi there,
Is the noise only when you depress the pedal, or is it when the clutch is released??
Please let me know.
As for noises, a shut off rattle from the driveline is considered normal, due to the tranmission.
Take care, and let me know, c4c5
 

·
Registered
Joined
·
396 Posts
Discussion Starter #3
It goes away when I push the pedal in. Sometimes its not their when the pedal is out but sometimes it seems to be louder than you would think. Iv worked on my share of cars and never heard something like this. The clutch engagement is smooth and works fine. I just want to make sure its not a problem starting to happen. thanks for your help
 

·
Registered
Joined
·
1,248 Posts
Hi,
Interesting, try this. When you hear the noise, just try leaning on the clutch pedal, just until the noise goes away, and let me know what you have.
I am suspecting the pilot bearing, or a clutch adjuster, however, let me know how far down you have to go, before the noise disappears.
Best to ya, c4c5
 
1 - 5 of 5 Posts
Top