Corvette Z06 Forum banner

1 - 20 of 61 Posts

·
Registered
Joined
·
184 Posts
Discussion Starter · #1 ·
Hi All,

I ran my '04 Z06 at the drag strip again this weekend and had mixed results. I am rather inexperienced and my 60ft times are still not very good but I am mostly concerned about my trap speeds.

Here are my mods:

'04 Z06
LG Headers with Cats/GHL Catback
Vararam VR-B2 with [email protected] Filter/Airbridge/Air Coupler
Low Temp. thermostat (fans set to come on early)
Nitto RIIs Rears (26psi) Nitto Regulars Front (42psi)
Dyno tuned @ 398RWHP / 389 RWTQ
(Rev. limiter bumped to 6800rpm but I shifted @ 6500rpm)

The weather was cool around 65F, track elevation 1000'.

My best times were:

12.6 @ 113.0 2.0 60'
12.7 @ 112.9 2.1 60'

I am not too concerned about my E.T. since I know improvement on the 60' would lower those but my trap speeds seem quite low for my mods (398RWHP). I am shifting @ 6500rpm and NOT bumping the limiter which has been bumped to 6800rpm. Car temps were hovering around 190F since I have a low temp thermostat and have the fans coming on early. I did also make sure that I read 120mph before shutting down after the traps.

Any suggestions on why my traps are so low? It bugs the heck out of me. I see many of you guys are getting 116+ mph traps with less power. Could there be something wrong with my car?

Thanks in advance for any responses.

Sunrise
 

·
Registered
Joined
·
1,852 Posts
IF nothing is wrong with the car and considering what you told me, I have one question, how do you shift?

Not telling you that you need to powershift, but to get the cars MPH we'll need to shift fast, not hard , but faster then usually, but you're Nittos so I would thing you're powershifting

also, when was that Dyno pulled?

luis
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #3 ·
COUTO1981 said:
IF nothing is wrong with the car and considering what you told me, I have one question, how do you shift?

Not telling you that you need to powershift, but to get the cars MPH we'll need to shift fast, not hard , but faster then usually, but you're Nittos so I would thing you're powershifting

also, when was that Dyno pulled?

luis
Thanks for your reply.

I did shift very fast (almost speed shifting) NOT power shifting but quite fast and smooth. I have the Mallett shifter.

The Dyno was ran about 1 month ago (March '05). I had another dyno 1 month before that (Feb '05) @ 390RW before replacing the BlackWing with the Vararam.

Could it possibly be the track I am going to? Commerce, GA?
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #5 ·
COUTO1981 said:
could possibly be the track, you are making good power, Im jealous of the headers and tune :cheers:

:pp: I'm jealous your E.T. and trap speed.... :)

"2003 50th anniversity Z06, 11.97 @117.97 stock "
 

·
Registered
Joined
·
1,852 Posts
sunrise said:
:pp: I'm jealous your E.T. and trap speed.... :)

"2003 50th anniversity Z06, 11.97 @117.97 stock "
hopefully soon I'll have headers and tune, and you'll very soon have your 11 second run as well :thumb:
 

·
Registered
Joined
·
1,062 Posts
You are producing 2 hp shy of 400 to the wheels with just headers, cat back and intake and making very good torque. I dont know but it seems kinda high. I almost want to say that the dyno you chose might have been a little forgiving. If you where driving like you said you where, and making the power the dyno said you where making with slicks, then you should be seeing 116+ very easily.

Just my opinion, could also be the elevation. :-?
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #8 ·
DavidGP said:
You are producing 2 hp shy of 400 to the wheels with just headers, cat back and intake and making very good torque. I dont know but it seems kinda high. I almost want to say that the dyno you chose might have been a little forgiving. If you where driving like you said you where, and making the power the dyno said you where making with slicks, then you should be seeing 116+ very easily.

Just my opinion, could also be the elevation. :-?

Hi there,

Yes...this is why I am puzzled....the elevation was only 1100' at the track...weather was not that humid and temp was not that hot. I will try another track to see what happens.
 

·
Registered
Joined
·
1,464 Posts
sunrise said:
the elevation was only 1100'
Elevation doesn't really mean anything. What was the uncorrected DA? Do you have the temp, hum, and press from that run?

Given your ET, your MPH seems about right.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #12 ·
benenati379 said:
Richard, why did you edit that. That was a good question. Headwind kills mph. Was there a headwind?
Thanks for your response.

I will double check the weather reports for the DA and all but I don't think there was much of a headwind.
 

·
Registered
Joined
·
624 Posts
I edited it because I also asked if he was full on through the traps, but he said so in his first post . . .

I was going to repost, but then had a meeting to go to . . .

What about knock retard?

Can anyone lend you their hp tuners so u can see if your car is knocking, which will definitely kill mph.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #14 ·
Richard Branca said:
I edited it because I also asked if he was full on through the traps, but he said so in his first post . . .

I was going to repost, but then had a meeting to go to . . .

What about knock retard?

Can anyone lend you their hp tuners so u can see if your car is knocking, which will definitely kill mph.

Knocking? Would that not show up on the dyno?

If it is how would I fix it?

Regards,
Sunrise
 

·
Registered
Joined
·
4 Posts
FYI, when I first got my 04 Z06 I ran it at the drags, no engine mods, stock tires, stock shift lingage, no tire presure change. I ran 12.84 @110 MPH (corrected for elevation). I did not hammer it out of the gates, basically drove it out with just enought throttle to keep it hooked up.

If you hammer it too hard at the lights it looks and sounds impressive, but your not going anywhere. Evaluate your launch, also you have to shift from third to fourth just as you near the end of the quarter which doesn't help on your E.T. or MPH.

I shift into second as the tach nears 6 grand, if you take it to the red line in first gear your actually decreasing your speed because the motor is working very hard in first gear to get the momentum (weight) of the car moving. If you wait to see 6,500 in first gear it will take longer to rev vs. shifting into second and building the revs and momentum in second gear. Give it a try. :yeadog:
 

·
Registered
Joined
·
17,744 Posts
Actually your ET is good, considering your 60' times :z:
 

·
Registered
Joined
·
2,014 Posts
Your et's are fine but your trap speed is a bit low. This is most commonly due to driver and weather. With those 60' times youe trap speed should be higher. As you hook better your trap speed will lower to some extent. Also some tracks are not calibrated well for trap speed. I know of one track whose left lane is notoriously 2-3 mph faster than the right lane. Anyway, don't sweat it until you have about 25 runs to compare too. Also, as I've stated many times the nitto 555r2's are not great launch tires. They stick better than f1's but are not particularly good from a dig. On a cool day with your mods and a 2.1 60' your trap speed should be 114-118+.
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #18 ·
Fast Randy said:
FYI, when I first got my 04 Z06 I ran it at the drags, no engine mods, stock tires, stock shift lingage, no tire presure change. I ran 12.84 @110 MPH (corrected for elevation). I did not hammer it out of the gates, basically drove it out with just enought throttle to keep it hooked up.

If you hammer it too hard at the lights it looks and sounds impressive, but your not going anywhere. Evaluate your launch, also you have to shift from third to fourth just as you near the end of the quarter which doesn't help on your E.T. or MPH.

I shift into second as the tach nears 6 grand, if you take it to the red line in first gear your actually decreasing your speed because the motor is working very hard in first gear to get the momentum (weight) of the car moving. If you wait to see 6,500 in first gear it will take longer to rev vs. shifting into second and building the revs and momentum in second gear. Give it a try. :yeadog:

So you suggest that I do not redline first gear? What about the 2nd-3rd gear shift and the 3rd to 4th shift? Everywhere else that I have been reading recommends that I take all gears 1st, 2nd and 3rd as close to redline as possible without bumping the limiter.

Regards,
Sunrise
 

·
Registered
Joined
·
184 Posts
Discussion Starter · #19 ·
Richard Branca said:
I edited it because I also asked if he was full on through the traps, but he said so in his first post . . .

I was going to repost, but then had a meeting to go to . . .

What about knock retard?

Can anyone lend you their hp tuners so u can see if your car is knocking, which will definitely kill mph.

Could you elaborate on the "knock" issue? How would I be able to detect this? You mentioned a HP tuner? Can you detect his via the Air to Fuel graph?

Could my tuner be at fault for this? I discussed it with him and he says it is the race track wanted me to go to another race track where they usually go to.

Any suggestions?
Regards,
Sunrise
 

·
Registered
Joined
·
1,050 Posts
Hey Sunrise!
As Rob said, a bad DA can reduce your mph & raise your ET's...When I have run on street tires, I would shift 1-2 @ 6200rpms to help minimize wheelspin on the shift. The other shifts should be made at 6500rpms & as FAST as possible. I'd say your ET's are ok for a beginner & your 60' times are average, but your mph is a bit low. My last runs on street tires last week at a rental netted me a best (in poor weather-hot/humid/high DA) of [email protected] w/ a 1.88 60' w/ wheel hop & you have more hp then me.
It's either weather or your shifting...Practice,practice my friend!!
Ron
 
1 - 20 of 61 Posts
Top