Corvette Z06 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
489 Posts
Discussion Starter · #1 ·
Just got my magnetic drain plug from Ecklers. The factory plug takes a 10 mm hex drive to remove and has a washer to seal the plug. The magetic plug has a 3/4 head and appears not to require a washer. I have applied teflon tape to the threads. I don't see any way a washer could work with this new plug. Clarification and confirmation needed. Thanks.
 

·
Premium Member
Joined
·
4,289 Posts
Hey cowboy. It was not a problem if you notice the new drain plug has a tapered seat. You just snug it up and it works fine. I just did this last month. Don
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #3 ·
dwjZ06 said:
Hey cowboy. It was not a problem if you notice the new drain plug has a tapered seat. You just snug it up and it works fine. I just did this last month. Don
Don, thank you for the information. I thought that was the case but just wanted someone a "lot" smarter than me to confirm and clarify.Thanks again.
 

·
Premium Member
Joined
·
4,289 Posts
Resist said:
Don't think you want to do this. Unless you want the tape in your fluids.
I agree. No need for the tape on the drain plugs. Don
 

·
Premium Member
Joined
·
4,289 Posts
MiamiCowboy said:
Don, thank you for the information. I thought that was the case but just wanted someone a "lot" smarter than me to confirm and clarify.Thanks again.
No problem. I thought the same thing at first until I tried it and snugged it up. Good luck.
 

·
Registered
Joined
·
489 Posts
Discussion Starter · #7 ·
Resist said:
Don't think you want to do this. Unless you want the tape in your fluids.
Good information but too late this time. Will have to live with consequences until I change the next time.
 
1 - 7 of 7 Posts
Top