Corvette Z06 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Im hoping this is just some sort of small security feature that i am over looking, but my car wont start. i drove it earlier today, started fine, i got home at about 2pm, took a nap and blah blah blah and just now at about 730pm i was going grocery shopping, and went into the car and nothing. lights work, radio works, when i turn the key to the ON position, the fuel pump primes, but the car wont start. the engine wont even turn over, i turn the key.... i get nothing, no clicking, no engine turn, nothing.

im gonna run to my other place and grab the other key real quick and try that. anyone got any suggestions? think its a bad battery??


EDIT-oh yea, i forgot, its a 2002 Z06 with 43 thousand miles on it.
 

·
Registered
Joined
·
3,212 Posts
Put the DIC in diagnostic mode, write down the codes, post them here.

Search the forum for "DIC diagnostic" for instructions, if you don't already know how to do this...
 

·
Premium Member
Joined
·
6,847 Posts
sounds like battery time to me .!!

they aren't the best out of the box..

optima red top seems to be the favorite replacement;
 

·
Registered
Joined
·
17,744 Posts
RocketSled said:
Put the DIC in diagnostic mode, write down the codes, post them here.

Search the forum for "DIC diagnostic" for instructions, if you don't already know how to do this...

Turn on the ignition but don't start the engine.
Press the "reset" button to turn off any warning messages
Press and hold "options" and
While holding "options", press "fuel" four times within a 10-Second period.
 
1 - 4 of 4 Posts
Top