Corvette Z06 Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
788 Posts
Discussion Starter · #1 · (Edited)
Just got back from LPE in Indiana. A long drive. Anyway, I got my magnacharger package installed. In a word...knarly. Tim at LPE gave me the grand tour. An amazing facility. State of the art equipment, and the cars...Holy ____ some amazing cars. I was lucky enough to get to see a C6 on the chassis dyno. It was silver and Tim said it had the Heads & Cam package. This is no joke....that car was the loudest street car I have ever heard, bar none. Apparently it had gutted cats and a corsa (pace car?) exhaust. After the dyno run, Tim asked the guy running the dyno what kind of exhaust it had. The guy didn't hear a word Tim said. Earplugs may be in order here. I'll post pics of my car as soon as I get my digital camera back, but my main reason for this post was to give credit where credit is due.

LPE is truly a top notch, high-class facility, with top notch employees. It was an experience I'll never forget. Everyone should get the grand tour there. Anyway, thanks Tim and LPE! Lingenfelter rules!!!!!!!!!!!!!!!! :yeadog:

Oh yeah, and thanks to Z06vette.com for infecting me with the mod bug. :jammin:

Adam
 

·
Registered
Joined
·
55 Posts
how many pounds of boost are you running??
 

·
Registered
Joined
·
788 Posts
Discussion Starter · #4 ·
Not sure. I haven't been able to look at the gauge while under boost, too chicken. Also, haven't taken the traction control off yet. It's the standard Maggie package at LPE, so my guess is a 3.2 pulley (whatever that equates to).

Here are some pics I got tonight.




 

·
Registered
Joined
·
37 Posts
itchy: What did they all do, clutch?, mount boost gage? What did you do for a hood? Is the maggie I/C? How long did it take them to do the install? Sorry for all the questions. If you don't mind me asking, how much did it cost?

The reason I ask is I am also from WI, and looking to upgrade my Z. I was thinking of having them do the work.

Thanks,
 

·
Registered
Joined
·
788 Posts
Discussion Starter · #6 ·
EVILZ,
I had the car transported in an enclosed trailer (with a 1.5 million dollar duesenburg). The transport company (PM me for info) has a 10 day window to pick up. They picked it up the 2nd day. Arrived at LPE 2 days later (4th of july weekend). LPE took about 3 weeks for the install. They installed the base maggie package which includes upgraded fuel pump, injectors. I opted for the polished version ($1000), the blackwing intake (mandatory, $288), the 160 thermostat (mandatory, $85), Boost bypass switch (mandatory with a Z06, $400), Coil covers (optional, $400), Lighted boost guage (optional, $300), LPE floor mats (optional, $100), and dyno testing (threw it in for free). You can get all the options & prices on LPE's website too. I then scheduled the transport company for pickup. They dropped the ball this time and kept putting me off (pebble beach and all, i care) so I cancelled them and picked the car up myself. Since I picked it up, I had to pay state sales tax. If you get it delivered out of state, there is no tax.

The hood I bought used for $500, so I saved about $1000 for not having LPE install a hood. It's not small change for this package, but I have confidence in the tune. And I can say I have a "Lingenfelter Vette", saaweeet.
 

·
Registered
Joined
·
2,092 Posts
Glad that you had a great experience w/our LPE brothers & sisters. Congrats on the set up as well.... :cheers: :thumb: :thumb:
 

·
Registered
Joined
·
3,166 Posts
Enjoy your new beast. Think its time for some sticky rubber!!
 

·
Registered
Joined
·
788 Posts
Discussion Starter · #12 ·
I'm holding off on the new tires since I still have the stock clutch and output shaft. I figure (hope) the fuse in the driveline will be the tires.
 

·
Registered
Joined
·
17,744 Posts
Sweet :jammin: :jammin:
 

·
Registered
Joined
·
117 Posts
Good to hear they are good to deal with. Here in the Milwaukee area there are just a few hack shops. I will probably end up sending my wifes CTS-V to Lingenfelter or Mallet. I may pay more but I will know I don't have a bunch of clowns working on my car.
 

·
Registered
Joined
·
1,957 Posts
itchynackers said:
I'm holding off on the new tires since I still have the stock clutch and output shaft. I figure (hope) the fuse in the driveline will be the tires.
Swaaeet Machine

Good Plan with the fuses.... Never thought of it that way but it makes sense. Any HP & Torque numbers ?
 

·
Registered
Joined
·
292 Posts
itchynackers said:
EVILZ,
....Boost bypass switch (mandatory with a Z06, $400.
Is this automatically kicked in? Under what conditions?

If you don't mind me asking, what's that little green display for behind the boost gage?

Have fun with your new LPE 'vette.
Sweet.
 

·
Registered
Joined
·
788 Posts
Discussion Starter · #17 ·
From what I understand, the boost can only come on above 1600 rpm. Below that, the bypass switch automatically opens. I assume its to reduce detonation or something like that.

Also, so far (1000 miles) the stock clutch has been fine. I will say though, that 1st and 2nd gear are useless if you want to take off quickly. My 1/4 mile times (gtech) have been lacking because of that, but my traps are steadily climbing as I learn to feather 1st & 2nd gear. I can't wait to get a good clutch, tires and output shaft. My 1/4 mile times should be in the very low 11's.
 

·
Registered
Joined
·
292 Posts
I can't wait to get a good clutch said:
Maybe some lower ratio gears should be included on the list. From what I've read in other posts, 3:15 gears have been used for very hp output motors to control the launch.
 

·
Registered
Joined
·
788 Posts
Discussion Starter · #19 ·
Actually, I was thinking a bit higher... in order to make use of 6th gear. I'm not sure what ratio would let 507rwhp pull 6th gear, but it would be nice, assuming I could hook 1st and 2nd.

Also, that display behind the boost gauge is my Gtech Pro Competition. When on, it glows blue.
 

·
Premium Member
Joined
·
652 Posts
itchynackers said:
From what I understand, the boost can only come on above 1600 rpm. Below that, the bypass switch automatically opens. I assume its to reduce detonation or something like that.

Also, so far (1000 miles) the stock clutch has been fine. I will say though, that 1st and 2nd gear are useless if you want to take off quickly. My 1/4 mile times (gtech) have been lacking because of that, but my traps are steadily climbing as I learn to feather 1st & 2nd gear. I can't wait to get a good clutch, tires and output shaft. My 1/4 mile times should be in the very low 11's.
Now you know why I have been running 273s and 315s.
Nice setup.
 
1 - 20 of 21 Posts
Top