Corvette Z06 Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
168 Posts
Discussion Starter · #1 ·
Hi all

I am getting really frustrated with my Z.

its an 02, with 22k miles on it. I notice then when i am cruising around in 4th or 5th gear at 3500rpm, and then i go full throttle, it seems to hesitate a bit, its as if its clearing its throat or something, and the flow of the exhaust seems a bit turbulent. I had the exhaust checked last week, i did find a small leak in a gasket which was replaced.

Other than that, in 1st 2nd and 3rd, the car pulls strong, its only when i am in mid rpms in 4th and 5th when i floor it that i get this little bit of hesitation. Is this normal? (its been 2 months that I have the car)
 

·
Registered
Joined
·
460 Posts
Check the plug wires. I had a similar problem a while back. The car seemed to be stumbling. I thought it was bad gas, but turned out it was misfiring due to a bad wire.
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #3 ·
did that set off any codes? i didn't get any codes for this, except for P0410 which i believe is not related.
 

·
Registered
Joined
·
1,852 Posts
it could be the plugs/wires, my cars running rich which made all my plugs wear prematurely and now I got exhaust leaks, not bogging but then again I dont keep it at 3500rpms :sneaky: I do feel a stumble when I let go of throddle but Im 99% sure its the AC on,
 

·
Registered
Joined
·
2,127 Posts
Bad wires, loose wires or bad plugs will NOT set a code. You have to run a missfire test withg a scanner.
 

·
Registered
Joined
·
168 Posts
Discussion Starter · #6 ·
my car is going to GM tomorrow, because the check engine and i keep getting P0410. I guess i will ask them to scan for misfires as well and see what gives.
 
1 - 7 of 7 Posts
Top