Corvette Z06 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
270 Posts
Discussion Starter · #1 ·
Sitting at a light. 03 Z06 19k miles. Car in neutral. All of sudden loose power in the engine. Still running, electrical fine, but no power. step on gas. sounds like its struggling with gas getting in. Then start to smell somthing buring. Okay that's when I shut it off. Light turns green limp it into gas station and call da dealership for the flat bed? Not too worried as have warranty. Any ideas? :puke:
 

·
Registered
Joined
·
17,744 Posts
No guesses here. Please let us know what you find. :cheers:
 

·
Premium Member
Joined
·
4,289 Posts
Fuel Pump? Check Fuses also. My guess without more info.
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #6 ·
I was thinking fuel pump or fuel filter as well.. No lights when it had troubles. I actually thought the sound was coming from someone else. Then when I stepped on the gas it felt like a go-cart. yikes!!
 

·
Premium Member
Joined
·
4,289 Posts
TJason25 said:
I was thinking fuel pump or fuel filter as well.. No lights when it had troubles. I actually thought the sound was coming from someone else. Then when I stepped on the gas it felt like a go-cart. yikes!!
How many miles? Fuel filter is good for more then a year or two on a low miles car. Let us know after you get it checked out.
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #8 ·
Okay just got off the phone with the dealership. They are not sure but think its a broken valve spring. Car has 19k miles on her. They are being super nice now that its a warranty issue. Geez. Could be a push rod. Hope not. They were able to get it running, but it runs super rough..They will let me know more after their engine specialist. AKA the warranty guy gives the final analysis.
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #9 ·
Dealership confirmed, Broken valve spring on cylinder number 8. They checked all cylinders no damage. Going to replace and should have back on Monday. Lucky it happened when I was at a light.
 

·
Registered
Joined
·
270 Posts
Discussion Starter · #11 ·
Got the Z back from the dealership...Finally a good service experience! They even washed it this time. Love it.
 
1 - 11 of 11 Posts
Top