Corvette Z06 Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
126 Posts
Discussion Starter · #1 ·
Hey guys, have any of you replaced the stock Z06 antennae with a power one ? If so, could you explain how complicated the installation was and how it turned out ? I assume you have to take the rear quarter/fender off, and also how was the fit and finish, what drilling was involved ? How long did it take, how much did it cost. Also, are there any other options ? Could you remove the antennae altogether and install some other kind of hidden one and fill the pre-existing hole ? Thanks !
 

·
Registered
Joined
·
2,317 Posts
Hi Quicksilver Boy !

You don't have to take off the Quarter fender to replace ! it's fairly simple if you follow the directions. I bought mine from MA
It took me about an hour and I also put on the switch where I could leave it down if I was playing CD's,


Rob :cheers:
 

·
Registered
Joined
·
5,442 Posts
Just take off the right rear red tail light lens. Reach in and do it. There is lots of do it your self instructions on the subject. When you get finished it is neat to watch the antenna go down. There is a slight delay after you take the key out ........before it goes down. I hardly ever listen to a CD so I didn't install that switch. I love the sound of the exhaust (B&Bs) my favorite music. Cost is about $100.00.........
 

·
Premium Member
Joined
·
4,362 Posts
It was the mod to the Z, did it myself with no problems. It was a easy installation. :cheers:
 

·
Registered
Joined
·
123 Posts
agree, an easy install incl. switch in the ashtray location

Fitchner Chev in MT on the other board fixed me up for about $100 plus shipping
 

·
Registered
Joined
·
1 Posts
Hey guys, have any of you replaced the stock Z06 antennae with a power one ? If so, could you explain how complicated the installation was and how it turned out ? I assume you have to take the rear quarter/fender off, and also how was the fit and finish, what drilling was involved ? How long did it take, how much did it cost. Also, are there any other options ? Could you remove the antennae altogether and install some other kind of hidden one and fill the pre-existing hole ? Thanks !
Hi I just fitted a new antenna but the new one isn’t working . The orange wire is live but the mast will not go up
Any ideas ? ?
 

·
Registered
Joined
·
600 Posts
If you have power to the antenna then you are not getting a signal from the radio to raise it. At least that is all I can think of. I have not done this on a Z06 but same idea as the 4th gen Camaro SS I had and installed one. I remember having to connect to a pin the harness that when the radio turned on, the antenna went up (unless you had a switch and had it off).
Sorry, not really much help, but this thread is so old, the directions link above is no longer there.
 
1 - 9 of 9 Posts
Top