Corvette Z06 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,436 Posts
Discussion Starter · #1 ·
"Service AH, Service ABS, Service TC"

I am getting a code "C1214", "Solenoid valve relay contact or coil circuit open".

There isnt a local dealer that can look at it until the 2nd of May, two weeks from now. I checked the fuses, theyre fine. I would like to fix this on my own. I went in to get a second key and fob today, and after paying almost $90. for the both I was directed to the service rep for assistance with programming them. He said that it would be a $46. service fee and that he couldnt get to it today, it would also be another two weeks.

I remembered at that point from reading a post on this board about "fob training" and told him forget it. I used the owners manual and programmed my second fob myself. I asked him if it was possible to do on my own and he told me a technician had to do it. He tried to rip me off and even worse if I had lost my other set of keys in the next two weeks I would really be up shit creek without a paddle.

Now I dont even want to go back there, I need to find out whats wrong and attempt to fix it myself. Ive done all the work to date on my Z myself, 04 shocks, hurst, vararam, euro headlights, skip shift eliminator, cat back etc. and Ive done a lot on my previous f body and Ive had my hayabusa completely apart and back together again. Im not ASE certified or anything but If I can find out whats wrong Im sure I can fix this.

Any help would be greatly appreciated.
 

·
Registered
Joined
·
2,388 Posts
eviLS6 said:
"Service AH, Service ABS, Service TC"

I am getting a code "C1214", "Solenoid valve relay contact or coil circuit open".
Seems like there have been a few other guys who have had this same problem here lately. If you have the factory service manual it will tell you how to trouble shoot any DTC (diagnostic trouble code).
 

·
Registered
Joined
·
1,279 Posts
I have a 02 Z06,with 24K miles,I had the same messages,with the same C1214 code...
I checked the short harness that is on the EBCM(electronic control brake module) for chaffing or rubbing it was fine..
I took it to the dealer they changed the EBCM :yeadog:
The part is about $1000..I would make sure that it is the EBCM before changing it :p Good luck..
PS...EBCM is the part that has bunch of brake lines on it,forward drivers side of the engine compartment.
 

·
Registered
Joined
·
17,744 Posts
Use the search function and type in C1214. Lots of idea's. :guiness:
 

·
Registered
Joined
·
806 Posts
I had the same code C1214HC. Turned out to be the EBCM and BPMV. All covered under extended warranty thankfully!! Total cost $2981.53 and less than 2 days in the shop. :D
 

·
Registered
Joined
·
109 Posts
I just had this happen to my 03......I nailed a 1-2 shift, then right after I get service ABS, service active handling......
 

·
Registered
Joined
·
1,436 Posts
Discussion Starter · #8 ·
janoz06 said:
I have a 02 Z06,with 24K miles,I had the same messages,with the same C1214 code...
I checked the short harness that is on the EBCM(electronic control brake module) for chaffing or rubbing it was fine..
I took it to the dealer they changed the EBCM :yeadog:
The part is about $1000..I would make sure that it is the EBCM before changing it :p Good luck..
PS...EBCM is the part that has bunch of brake lines on it,forward drivers side of the engine compartment.
Yup, just took the car in to the dealer friday and it is indeed that $1000. dollar part, I think its the ABS module. Problem is Im out of warranty and had to fork up the cash, and here in hawaii its actually $1200....Ill elaborate on this in another post here.
 
1 - 8 of 8 Posts
Top