Corvette Z06 Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
286 Posts
Discussion Starter · #1 ·
I took the beast to the dyno the other day with no cats and I put in the SIMS this time and got 375.9 RWHP at 365RWT. The car still runs rich on the motor 12.2 on the wideband but the kicker is with the Nitrous on. When I nailed the 100 shot the fuel mixture went lean as hell with the SIMS 14.5 with the nitrous on I thought the engine was done. I jetted up the fuel two stages and cam out at 11.9 fuel to rich:mad: . But the car made 470RWHP the same as before so I will lean it up some more and take it back. I just wanted to share that is you are running no cats and SIMS and use nitrous be careful because it makes it LEAN on the nitrous. I think with the back o2’s not reading mixture that is the problem.

Cheers:cheers:
:cheers:
 

·
Registered
Joined
·
188 Posts
I doubt that the simms had anything to do with the car running too lean , for two reasons :

1) The PCM doesn't read the O2's at WOT. I'm assuming that you didn't activate the N2O until you were close to WOT (more than 80% of full throttle).

2) The rear O2's are only used to monitor whether or not the cats are working. The AFR is monitored by the pre-cat sensors.

It sounds like you changed a couple of things , no cats , different jets , O2 simms , etc. If that's the case then it probably had more to do with the N2O jets than anything else. Since the car ran slightly rich on motor , I doubt that the PCM or sensors was the cause.
 
1 - 2 of 2 Posts
Top