Corvette Z06 Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
266 Posts
Discussion Starter #1
When I returned from a "run" Sunday I noticed some oil under right rear of car. When I looked under car, the rear anri-roll bar was dripping oil and the underside of rear framework had oil on it. No obvious signs of leakage. Definitely not from front of car.

Any ideas??

Goes to Mr. Goodwrench on Fri.. /phpBB/images/smiles/icon_cry.gif

Thanks,

2k
 

·
Registered
Joined
·
19,096 Posts
Mr Cobra:

Might be a rear end seal....had one replaced on my '99.

Let us know what the dealer finds...good luck.

Zippy /phpBB/images/smiles/icon_smile.gif /phpBB/images/smiles/icon_smile.gif
 

·
Registered
Joined
·
2,459 Posts
That happened to me a few weeks ago. It was the "left side differential side plate" - what ever the hell that is.
 
T

·
Guest
Joined
·
0 Posts
Also could be the MN6 trannie blew fluid out the vent hole which is at the top of the trannie. These MN6 get too hot too quickly and once fluid starts to foam, fluid is ejected out that vent tube.
Has happened to me at least 3 times during racing or long term high RPMs
 

·
Registered
Joined
·
266 Posts
Discussion Starter #6
Thanks all.

We will keep you posted.

2k
 

·
Registered
Joined
·
266 Posts
Discussion Starter #7
Got it back from dealer. The repair was as follows.

"Tighten Rear Differential oil fill Plug"

Glad I paid big bucks for last service.

Car is still a virgin!

Luv that Autoweek thing, Z06 the main object of America's Best..... /phpBB/images/smiles/icon_biggrin.gif

Thanks all for your input!

2k
 

·
Registered
Joined
·
309 Posts
Beware of the old "tighten" routine. I had my Z at the dealer three times for a leaky diff. First two trips: 1)bolts were loose and 2)Loctite not used. R/R differential housing and replace. Now on the third trip I finally got a straight answer, the seals were bad. Unfortunately they are a special order part which arrived yesterday and will be installed on Monday-my fourth trip. My advice....if it leaks again demand new seals!
Just my .02
 

·
Registered
Joined
·
266 Posts
Discussion Starter #9
Mar,

Thanks for your concern. Took car out after I picked it up and tested. Holeshotted a superbike during the "Test". /phpBB/images/smiles/icon_biggrin.gif (Closed circuit controlled conditions, of course) No oil on components. I will do some more on this Sunday and post results.

Thanks,

2k
 

·
Registered
Joined
·
2,459 Posts
My car started leaking a bit, and it wasn't too bad, so I didn't worry about it. Then one day it started puddling...

I took her in the next day. If its just spotting a bit, I would just keep an eye on it.
 

·
Registered
Joined
·
266 Posts
Discussion Starter #11
My little Sunday event was successful. I guess we can close the book on this one. Can't believe it was a loose drain plug.

Thanks to all for your input,

2k
 
1 - 11 of 11 Posts
Top