Corvette Z06 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone,

01' Z06's LS6 engine - Are they the only one w/ ring flutter problems which is the cause for oil consumption ?

So no LS1 are affected & no oil consumption problems.

Thx.
 

·
Registered
Joined
·
2,486 Posts
I've heard that there were some LS1's that had oil consumption problems but am unsure about the cause. I've never seen a percentage # of 01 LS6's that were oil users but i'd bet the percentage was rather small. Anyone know what % of 01's were oil burners?
 

·
Premium Member
Joined
·
20,625 Posts
I've seen a few LS1's go in for new rings, but these particular vettes had been autox'ed and drag raced. Most of the LS6's (01's) do burn some oil. all the 01 Z06 owners I know put at least a quart in between 1500-2500 miles. I changed my oil at 1100 miles (no burning before the change) and had the low oil level light come on at 2800 miles. 1700 miles, one quart, high performance and just blasting around = acceptable to me. I'm just gonna drive it until I get to one quart every 500 miles! Just my observations from owning my Z06 for 3 months. :D
 

·
Registered
Joined
·
2 Posts
I have an 01 Camaro SS, I haven't had it very long, but I think it has a little oil consumption problem. One of the other boards I frequent is an F-body related board and there are many people who experience oil consumption.

With the amount of people noticing this on there f bodies and corvettes I would hazard to say that it is not a problem, but that it is normal, not that I have ever considered oil consumption normal.
 

·
Registered
Joined
·
5,414 Posts
ALL`

LS1's & LS6's...........'99-'01's...........are potential users...........
A TSB was put out on this a while back............
 
1 - 5 of 5 Posts
Top