Corvette Z06 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
I spent last weekend at Road America running with the Alfa Romeos. I think more Vettes were there than Alfas. :lol:

I had a pretty good scare Sunday morning. See http://www.alltel.net/~sb32511/Valve/valve.html

I turned a 2:53 with my rock hard Kumho 712s and conservative braking. Ran across a lot of old faces and met some new.

I went up there with Ted Hughes. He towed his SC 435 Mallet there and I was able to tow tow my car back with his trailer. It's kind of different fueling the diesel and having a race car getting race gas by the 5 gallon can at every stop. My thanks and gratitude go to Ted for getting me out of a jamb.

Oh yea, Ted was able to turn a 2:38 on his first day at the track. That is after 40 minutes of practice time.

I have pictures and will get them on a web page to share later.
 

·
Registered
Joined
·
0 Posts
Sorry to hear that Gerry. :( Those Fieros don't hold up as well as a Z06. :lol: JK Bro!! :(

Hope you are back up and running soon, and glad there is no serious damage. :)

Thanks for sharing the pix with the forum. :cool:
 

·
Registered
Joined
·
93 Posts
Discussion Starter #3
Thanks Frank. The only part being replaced is the push rod. You don't need to be told what goes through your mind after hearing a bang like that. I would say I was lucky, but being that it's on GM, they got lucky :D
 

·
Z06 Maniac!!
Joined
·
1,541 Posts
Gerry, glad you had fun and that the damage is minimal. :D I have to get to that track someday. Was your rockers, push rods, etc, all stock? I can't believe that happened.
 

·
Registered
Joined
·
1,465 Posts
Bummer

The engine factory must have ran out of loctite when putting in the rocker studs in the heads :roll: . Hopefully the dealer checked all the rocker studs before they buttoned it back up, it would suck to have another one back out on ya.
 

·
Registered
Joined
·
93 Posts
Discussion Starter #7
I looked at the bolt and bolt holes and I saw no evidence of lock-tite. I wonder if it is common practice to use it? The tech re torqued all rockers on both banks and she is back together now.

Ron, everything in my engine is stock LS1 1999. I already had the decision made to upgrade all springs if they were damaged.

Some times shit just happens.
 

·
Registered
Joined
·
93 Posts
Discussion Starter #9
fcalmes said:


I can tell you fom personal experience....it is a DAMN GOOD running '99 FRC!! :eek: :eek:
:p :p :cheers:
 
1 - 9 of 9 Posts
Top