Corvette Z06 Forum banner
1 - 5 of 5 Posts

·
Registered
2006 Z06
Joined
·
4 Posts
Discussion Starter · #1 ·
I use the OBD LX recommended by TrackAddict, rather, I try... With TrackAddict recognizing the OBD device, as soon as I started the engine, the DIC says that the traction control mode is changed and the fuel gauge is pegged at Empty. I turned of the engine and I don't want to do this again. The idea that the TrackAddict / OBD link LX acts as anything but a monitor makes me uncomfortable. If it's going to do anything with traction control, I'm not going to drive with this setup.

Has anyone else seen something like this? Have I missed a setting?

  • 2006 Z06, 20K miles
  • TrackAddict: downloaded in May '21, but I cannot find a version number
  • OBD2 link LX: purchased from Amazon 2-3 years ago, still works as expected on my other cars
 

·
Z06 Tech Advisor
Joined
·
1,865 Posts
I maybe wrong but the LX version of OBDlink does not support GMs GMLAN on-board network that was used starting with the C6 for GM Enhanced functions.

If that is the case, you would need to go to the OBDlink MX+ model, which also is Bluetooth

Also, could try and use OBDlink's OBDWIZ scanner software on a laptop and see if that works correctly
 

·
Registered
2006 Z06
Joined
·
4 Posts
Discussion Starter · #3 ·
I maybe wrong but the LX version of OBDlink does not support GMs GMLAN on-board network that was used starting with the C6 for GM Enhanced functions.

If that is the case, you would need to go to the OBDlink MX+ model, which also is Bluetooth

Also, could try and use OBDlink's OBDWIZ scanner software on a laptop and see if that works correctly
Thanks! I'll look into that in the morning.
 

·
Registered
2006 Z06
Joined
·
4 Posts
Discussion Starter · #4 ·
I bought the MX+ and it works. Thanks for the tip!
With information and pointers form this and several other posts, I assembled a 'system' that works well, but intermittently. I'm using a dedicated Samsung S5, the OBDLink MX+, Qstarz BT-Q818XT and the Panavise 809 windshield mount. When it works, it works well. The windshield mount is excellent.

Some observations:
Plug the OBDLink in after the engine is started -- there will be fewer odd messages on the gauges / DIC. The messages vary and it may be that there is a longer wait after engine start for the bus to settle. I'll take better notes next time and share them if I find consistency.
Next, and again without any methodical debug, I want to believe that there is a proper startup sequence with the engine, phone, GPS and OBDLink; I'd not like to think that there are more difficult (communication, version, power...) problems to find. It worked well 2-3 times, but more often TrackAddict was not seeing the GPS or the OBDLink or both by the time I'm getting on the track. I'll play with this more too. Please understand that I'm blaming no product and no one other than myself for not spending more time reading the documentation and getting it to work when I wasn't at the track.
The Samsung S5 was my old phone and it was not 'cleaned' before this use. There may be things running that don't need to be on the phone. I'll look into this as well.

I'll post if I find anything useful. And Thanks again for pointing me to the MX+.
 

·
Z06 Tech Advisor
Joined
·
1,865 Posts
I suspect most people do not use this track software, GPS and connecting to the vehicle via the OBDLINK MX+

All I can state is you also need to install if using just a cellphone is the OBDLINK OBD-II scanner APP and check with that once in a while to click on "updates" and see if there is any firmware updates for the MX + and keep it up to date.
 
1 - 5 of 5 Posts
Top