Corvette Z06 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
407 Posts
Discussion Starter · #1 ·
Which under drive to install with no problems with electrical system, 10% or 25%- is there something in the middle.
How much power is their to be made with each.
Please chime in.
This is an easy mod, that i have not done yet...
 

·
Registered
Joined
·
314 Posts
Go with the Pulley from ASP - 25% underdrive with no alternator pulley...

Not that easy of a mod since the steering rack has to be removed.
 

·
Registered
Joined
·
3,817 Posts
I was told the ASP pulley is kind of tricky to install and could result in vibration problems if not done correctly. Also, there could be clearance issues if you have a dual roller timing chain. As mentioned, not worth it unless you are doing a cam install at the same time. :thumb:

Bob
 

·
Registered
Joined
·
152 Posts
Cool.....So a 25% under drive pully would render the alternator 25% less effective?...Just confused on the math here... :crazy:
 

·
Premium Member
Joined
·
652 Posts
Before s/c I had the MTI pulley. No problems with ac or alternator.
Got 6 rwhp on a stock block.
If you are not doing a cam at the same time you have to ask yourself is 6 hp worth the $s.
 

·
Registered
Joined
·
17,744 Posts
Icewasp said:
Cool.....So a 25% under drive pully would render the alternator 25% less effective?...Just confused on the math here... :crazy:
It will just means everything will turn 25% slower at any given RPM. Which may or may not cause a charging problem during extending periods of Idling or if you have a big time stereo amps. :cheers:

.
 

·
Registered
Joined
·
5,046 Posts
IT L GO said:
It will just mean everything will turn 25% slower at any given RPM. Which may or may not cause a charging problem during extending periods of Idling or if you have a big time stereo amps. :cheers:

.
With a stock power draw (ie no killer stereo added), you will be alright under most driving conditions. Never have had a problem using them on other cars in the past, but I'm not one to idle for long... :p
 

·
Registered
Joined
·
2,127 Posts
I am using one and have no problems with lights, ac etc.
Volts are still at 14.3 at night, normal cruise
But you need a cam for all that work.
 

·
Registered
Joined
·
9,957 Posts
22655TD said:
I am using one and have no problems with lights, ac etc.
Volts are still at 14.3 at night, normal cruise
But you need a cam for all that work.
DITTO!

Go for it when you do a cam..its seamless but not worth the money imho without a cam mod.

HTH
 
1 - 13 of 13 Posts
Top