Corvette Z06 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hello, i just purchased a 2007 Z06. and I have noticed that the front two rotors are nor wearing evenly.

If you look at the rotor the most outer and inner parts of the rotors are shinny...From the brakes being applied.

Right in the center you can tell the brakes are not contacting the rotors because their are no wear indicated in that area. It is plainly visable because there is still rust deposits dead in the center of the rotor where the brakes contact the rotors.

Any advice????

Thanks!
 

·
Premium Member
Joined
·
5,475 Posts
Hello, i just purchased a 2007 Z06. and I have noticed that the front two rotors are nor wearing evenly.

If you look at the rotor the most outer and inner parts of the rotors are shinny...From the brakes being applied.

Right in the center you can tell the brakes are not contacting the rotors because their are no wear indicated in that area. It is plainly visable because there is still rust deposits dead in the center of the rotor where the brakes contact the rotors.

Any advice????

Thanks!
You might want to try the aftermarket one-piece pads instead of the little "padlets" that the C6Z comes with,,,,I'd bet that will solve the issue.

Jimbo
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Could you please point me on the right direction?
I just want to make sure I get the best ones out there.

And thanks again!!!
 

·
Registered
Joined
·
5 Posts
any luck on this? I just installed the padlets and have a similar problem, but the rust ring is closer to the center of the hub. It's like the padlet isn't making full contact.

Could you please point me on the right direction?
I just want to make sure I get the best ones out there.

And thanks again!!!
 
1 - 5 of 5 Posts
Top