Corvette Z06 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,852 Posts
Discussion Starter · #1 ·
just some background here, I race my car time to time, it has alot of highway crusing miles, but on take off Im pretty hard on it, My clutch has been glazed last year for the first time when I poppled the clutch at 50mph on 6th gear (dont ask :crazy: ) It has never spun on power shifts (suprisingly) except twice when I went from 2nd to 5th at the strip (no $hit)...

this weekend traveling to the shore I used cruised control excpet on the first small bridge I hit 4th up to 14x mph then on a longer one I attempted top speed, If trying to speed like that isnt stupid enough, I had the radio blasted and I shifter into 5th on an incline, I did give it sometime to shift into and I think it accelerated a bit in fifth (not sure) but all of a sudden the car fell on its face and the RPMs shot to red line, then it would come out of gear and it would cruise but if I attempted to give it throodle the clutch would spin and the car wouldnt move up, I gave it a few miles up and everything went back to Brand New...

Im just curious exaclty what part gave up, Obviously I know it was the clutch per say, But I hear about the Slave cylinder, Is that what gave in...

BTW the clutch and everything held up fine the rest of weekend and another 300 mile drive :pp: , even a few burnouts for spectators :lol:
 

·
Registered
Joined
·
2,888 Posts
i think it was the fact there's a screw in your tire that you don't know about and god was trying to save your life. :D
 

·
Registered
Joined
·
1,557 Posts
My clutch would do the same sort of thing when it was on its last legs. With how hot it has been this week and running it hard, your clutch overheated and started slipping. Once it cooled down it was fine again. Mine did that for a couple months, consistantly getting worse until I replaced it.

Going to five0joe's party last year, it took close to 2 hours to go from DC to Baltimore due to traffic and it was high 90's outside. When I pulled out of the toll plaza, I tried to run it up through the gears. When I hit 3rd, it just revved freely, zero acceleration. It took half an hour before the cluch would grab normally again.
 

·
Registered
Joined
·
1,852 Posts
Discussion Starter · #4 ·
Javelin said:
My clutch would do the same sort of thing when it was on its last legs. With how hot it has been this week and running it hard, your clutch overheated and started slipping. Once it cooled down it was fine again. Mine did that for a couple months, consistantly getting worse until I replaced it.

Going to five0joe's party last year, it took close to 2 hours to go from DC to Baltimore due to traffic and it was high 90's outside. When I pulled out of the toll plaza, I tried to run it up through the gears. When I hit 3rd, it just revved freely, zero acceleration. It took half an hour before the cluch would grab normally again.

thats the thing though, it did that after an hour of highway, I couldnt of asked not to do that, I was stupid, but after a mile of letting it come back to normal, I drove another 1.5 hours on the highway, then got to coastal highway in traffic, did a burnout, actually the engine even bogged down whihc meant the clutch and tires were both grabbing :-?

anyways, I dont know how much long it will last, but its been a tough 21k for it, I dont want to spend the money now for a new, and I Love the stock one, BUt i beat on it alot :cheers:
 

·
Registered
Joined
·
1,281 Posts
Another person with clutch troubles besides me. Mine are just the opposite though. Mine happen at take off and shut down (when at a standstill) but it works fine any other shift or speed.
 

·
Registered
Joined
·
1,852 Posts
Discussion Starter · #6 ·
spdrcrj said:
Another person with clutch troubles besides me. Mine are just the opposite though. Mine happen at take off and shut down (when at a standstill) but it works fine any other shift or speed.

after 21k miles, Drag radials launches, maybe a thousand of 2nd gear fish tails/donuts/burnouts, I dont think thats a problem, I was on a uphill, not listening to the car to catch it sooner doing 140mph+, I couldnt ask for more out of that clutch :pp:
 
1 - 6 of 6 Posts
Top