Corvette Z06 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Mine reads 73 degrees all the time and I'd like to check the sensor for dirt/debris. Anyone know where it's located? TIA.
 

·
Premium Member
Joined
·
7,247 Posts
Yep Norm, IIRC It's up front on the passenger side under the large flat plastic cover in front of the radiator. Nothing to clean as i remember, it may be bad or disconnected somehow though.

You'll know when you find it, it looks just like an outside temperature probe.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #4
Thanks Joe. I lifted the hood and looked where you said and followed a cable to a connector and a sensor that stuck through the plastic panel. I unplugged and reseated the connector then laid down under the front of the car and found what I believe to be the temp sensor. It has a small hole in the bottom and I cleaned it out with my finger. It's all good now. :yeadog:

Thanks!

 

·
Registered
Joined
·
1 Posts
I believe it is in the front fascia. I'll bet someone chimes in with the exact location.
It's on the left side of the engine up under the z06 cover if standing on the outside it's on the right mine was broken it's been repaired it was reading 300 degree but now it's not
 

·
Z06 Tech Advisor
Joined
·
1,814 Posts
The sensor on the left side of the engine is the coolant temp

For outside air temp is in the lower right bottom of fascia, below right headlight,
just follow the wiring from right frame to it
 
1 - 8 of 8 Posts
Top