Corvette Z06 Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter · #1 ·
Hello All-

Have about 5k miles on 04z...passenger side window stopped working for two weeks...and than started again...now drivers side window is not working...I live in FLA and have tinted windows..do not know if the heat and tint are factors...

Also whenever I turn car slow I hear thumping noise in back right side...seems to be strut/shock issue?

Has anyone else experienced this issue? any recommendations?

Thnx in advance!
 

·
Registered
Joined
·
5,333 Posts
Don't know what could be screwing up the windows but I seriously doubt the tint has anything to do with it. An intermittant problem like that can usually mean a loose connection somewhere.

Are you sure the sound you're hearing in slow turns isn't the rear axle click? "Posi-tractions" do that.

Sounds like it's time for a warranty trip to the dealer and see if they can figure it out.

Good luck and keep us posted.

Charlie
 

·
Registered
Joined
·
5,046 Posts
Window issues: Do you have any stored error codes. If it is a loose connection or a computer module issue it should should up as a code.

The thumping sound: Have you crawled under the rear end and checked to see if anything is loose. This could be lots of things from a loose sway bar or shock or even the gears.

I would take it in and have it checked if any codes are coming up. the window modules have been known to fail and the part is not cheap.

Good Luck.
 

·
Registered
Joined
·
3,035 Posts
I had the thump to. If put your hand behind the pass. seat and press against the back wall, you'll notice it flexes and makes a thump kinda noise. It's common. Mine stopped. I don't know how but it did. It may have something to do with the pass. seat being all the way back.
 
1 - 4 of 4 Posts
Top